Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#12220 closed defect (fixed)

Timezone list is incorrect after upgrading timepicker to 1.5.5

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.2
Component: general Version:
Severity: normal Keywords: jquery jqueryui
Cc: Branch:
Release Notes:

Corrected display of UTC timezone when format is ISO8601 (regression with upgrade to jQuery UI Timepicker 1.5.5 in #11019).

API Changes:
Internal Changes:

Description

jQuery UI Timepicker was upgraded to 1.5.5 in #11019. [object Object] is displayed for the UTC entry in the timepicker's timezone list rather than Z when the format is ISO8601. See discussion in comment:6:ticket:11413.

The proposed patch also provides some minor improvements when directly editing the timepicker text field, although issues still remain in which the cursor will move to the end of the line while attempting to make an edit.

Attachments (4)

t12220.patch (2.5 KB ) - added by Ryan J Ollos 5 years ago.
Patch by Jun from #11413.
Trac 1.0-stable.png (71.5 KB ) - added by Ryan J Ollos 5 years ago.
Trunk Empty Text Field.png (55.6 KB ) - added by Ryan J Ollos 5 years ago.
Trunk Text Field with Value.png (61.3 KB ) - added by Ryan J Ollos 5 years ago.

Download all attachments as: .zip

Change History (12)

by Ryan J Ollos, 5 years ago

Attachment: t12220.patch added

Patch by Jun from #11413.

by Ryan J Ollos, 5 years ago

Attachment: Trac 1.0-stable.png added

comment:1 by Ryan J Ollos, 5 years ago

I'm not so familiar with the specifics of these date and time formats so I'll ask - was it intentional to change the label for +00:00 to Z?

On 1.0-stable the label is +00:00 and the value is Z.

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

by Ryan J Ollos, 5 years ago

Attachment: Trunk Empty Text Field.png added

by Ryan J Ollos, 5 years ago

comment:2 by Ryan J Ollos, 5 years ago

Another potential issue, which is also seen on 1.0-stable - when clicking on an empty text field the datetimepicker appears and has the Z timezone selected (+00:00 on 1.0-stable). An example of this is the Due field on /admin/ticket/milestones (left image). Should the user's timezone be selected by default? Additionally, perhaps the current time should be selected since the current date is selected.

The text fields that display a default value, such as Released on /admin/ticket/versions, display a default value with the user's timezone (right image).

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

in reply to:  2 ; comment:3 by Jun Omae, 5 years ago

Replying to Ryan J Ollos:

Another potential issue, which is also seen on 1.0-stable - when clicking on an empty text field the datetimepicker appears and has the Z timezone selected (+00:00 on 1.0-stable). An example of this is the Due field on /admin/ticket/milestones (left image). Should the user's timezone be selected by default?

Right. I created #12225.

Additionally, perhaps the current time should be selected since the current date is selected.

I think no need to select current time. User can use Now button to set current time. Mostly, exact time is used. E.g. 9:30, 12:00. If current time is selected, we would have to use time sliders every time.

in reply to:  3 comment:4 by Ryan J Ollos, 5 years ago

Replying to Jun Omae:

Replying to Ryan J Ollos:

Another potential issue, which is also seen on 1.0-stable - when clicking on an empty text field the datetimepicker appears and has the Z timezone selected (+00:00 on 1.0-stable).

Do you have an opinion in whether Z or +00:00 should be displayed in the timezone selection list? Using Z seems confusing to me, but maybe that's convention?

I think no need to select current time. User can use Now button to set current time. Mostly, exact time is used. E.g. 9:30, 12:00. If current time is selected, we would have to use time sliders every time.

That makes sense.

comment:5 by Ryan J Ollos, 5 years ago

Owner: set to Ryan J Ollos
Status: newassigned

comment:6 by Ryan J Ollos, 5 years ago

Proposed changes in log:rjollos.git:t12220_tz_list. In particular, does the change in [b68cbb60/rjollos.git] make sense, or rather is the label used in some way that I do not see?

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

in reply to:  6 comment:7 by Ryan J Ollos, 5 years ago

Replying to Ryan J Ollos:

In particular, does the change in [0524ce73/rjollos.git] make sense, or rather is the label used in some way that I do not see?

I re-read #11413 and did some testing. The behavior looks correct to me after [0524ce73/rjollos.git] (note the use of None rather than [] that caused the problems reported in #11413).

comment:8 by Ryan J Ollos, 5 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Committed to trunk in [14362].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.