Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12194 closed defect (fixed)

Version control backends shouldn't be required

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.2
Component: version control Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Version control components are not required when there is a repository for the backend. This reverts behavior added in 1.1.2 ([12820]).

API Changes:
Internal Changes:

Description

After [12820] the version control backend is required when a repository is configured for that backend. The implementation was modeled after the database backend classes, however the database backend is different in that the Trac instance is effectively disabled if the database backend component required by the [trac] database string is disabled. The user may wish to disable the version control backend even when a repository is configured for that vcs so we should not make the backend required.

Attachments (0)

Change History (4)

comment:1 by Ryan J Ollos, 6 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

comment:2 by Ryan J Ollos, 6 years ago

Travis has been erroring with Python 2.6 since [14293]. I think I see what the issue is and will commit a fix shortly.

comment:3 by Ryan J Ollos, 6 years ago

I'm unsure of what the issue is, but the functional test execution is hanging at trunk/trac/tests/functional/testcases.py@:83#L48. I'll investigate further tomorrow.

comment:4 by Ryan J Ollos, 6 years ago

I'm unsure of the mechanism of test failure, but it seems to be fixed with [14305].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.