Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

#12147 closed defect (duplicate)

UnicodeEncodeError: 'ascii' codec can't encode character u'\xe7' in position 16: ordinal not in range(128)

Reported by: paulo Owned by:
Priority: normal Milestone:
Component: timeline Version: 0.12.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /timeline, Trac issued an internal error.

Researched here in http://trac.edgewall.org/ site but have not found a solution to my case could help me?

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.107 Safari/537.36

System Information

Trac 0.12.2
Babel 0.9.5
Docutils 0.8.1
Genshi 0.6
mod_python 3.3.1
MySQL server: "5.5.29-0ubuntu0.12.10.1", client: "5.5.29", thread-safe: 1
MySQLdb 1.2.3
Pygments 1.5
Python 2.7.3 (default, Sep 26 2012, 21:53:55)
[GCC 4.7.2]
pytz 2011k
RPC 1.1.2
setuptools 0.6
Subversion 1.7.5 (r1336830)
jQuery 1.4.2

Enabled Plugins

docrender 0.2
graphviz 0.7.6dev
GridModify 0.1.5
MovieMacro 0.2dev-r12038
STractistics 0.5.0b
ticket-clone Rev
TicketSidebarProvider 0.0
TracAccountManager 0.3dev-r9929
Tracchildtickets 2.5.2
TracCustomFieldAdmin 0.2.8
TracDynamicFields 2.2.0dev
tracgviz.api N/A
TracHoursPlugin 0.6.0dev
TracMasterTickets 3.0.3
TracProgressMeterMacro 0.2
TracStats 0.5
TracSumFields 1.0.1
TracWysiwyg 0.12.0.3-r9676
TracXMLRPC 1.1.2
worklog 0.2

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/timeline/web_ui.py", line 213, in process_request
    format='rss')
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/web/href.py", line 181, in <lambda>
    self._derived[name] = lambda *args, **kw: self(name, *args, **kw)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/web/href.py", line 175, in __call__
    href += '?' + unicode_urlencode(params, self.query_safe)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/util/text.py", line 118, in unicode_urlencode
    k = quote_plus(str(k), safe)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe7' in position 16: ordinal not in range(128)

Attachments (0)

Change History (2)

comment:1 by anonymous, 4 years ago

Component: generaltimeline

comment:2 by Jun Omae, 4 years ago

Resolution: duplicate
Status: newclosed

A duplicate of #10121.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.