Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

#12132 closed task (duplicate)

Remove or deprecate util.compat.py_groupby

Reported by: Tim Graham <timograham@…> Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Seems this was added for a bug in Python 2.5 which has been fixed. I see other functions in this module have been kept around for backwards compatibility with plugins. Do we need to do so here? If so, could we raise a deprecation warning and schedule the function for removal in some future release?

Attachments (0)

Change History (3)

comment:1 by Ryan J Ollos, 4 years ago

Milestone: 1.3.1

Nice find. Based on a read of [7629], it looks like we can schedule it for removal in milestone:1.3.1. I'll plan to roll this into #11901, but will leave open for now to see if there are any further comments. Before closing I'll add a note to the codebase to indicate that the compat function will be removed in 1.3.1.

comment:2 by Ryan J Ollos, 4 years ago

py_groupby was added to Trac in [7629], and the issue fixed in Python-issue:2246.

Added comment to schedule for removal in milestone:1.3.1 in [14188:14189].

comment:3 by Ryan J Ollos, 4 years ago

Milestone: 1.3.1
Resolution: duplicate
Status: newclosed

Duplicate of #11901. See latest proposed changes in comment:22:ticket:11901.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.