Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#11891 closed defect (fixed)

Entry is stored in ticket change table when whitespace change in text field

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: low Milestone: 1.0.3
Component: ticket system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Text fields with whitespace changes are not stored in the ticket_change table.

API Changes:
Internal Changes:

Description

To reproduce:

  • Change the value of any field, e.g. change milestone field from milestone1 to milestone2.
  • Add whitespace to the value of a text field, e.g. change keyword field from kw1kw1 .
sqlite> SELECT oldvalue, newvalue FROM ticket_change WHERE time=1419227103370485;
kw1|kw1
milestone1|milestone2
9|

The value is not displayed in the ticket changelog because old == new is filtered out: tags/trac-1.0.2/trac/ticket/web_ui.py@:1829#L1783. The change is not saved in the changelog unless another field is also changed because the changes are discarded if all props are unchanged: tags/trac-1.0.2/trac/ticket/model.py@:277-280#L260.

Attachments (0)

Change History (3)

comment:1 by Ryan J Ollos, 6 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: newclosed

Committed to 1.0-stable in [13553], merged to trunk in [13554].

comment:2 by Ryan J Ollos, 6 years ago

Test case failures on MySQL should be fixed in [13558], merged in [13559].

in reply to:  2 comment:3 by Jun Omae, 6 years ago

Replying to rjollos:

Test case failures on MySQL should be fixed in [13558], merged in [13559].

Unrelated to MySQL. I think it would be easy to use ORDER BY field for that case.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.