Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11885 closed defect (fixed)

AttributeError: 'RepositoryManager' object has no attribute 'repository_sync_per_request'

Reported by: Peter Suter Owned by: Peter Suter
Priority: normal Milestone: 1.1.3
Component: version control Version: 1.1dev
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Fixed regression in [13393] due to use of removed repository_sync_per_request attribute of RepositoryManager class.

API Changes:

Description (last modified by Peter Suter)

trac-admin command changeset added fails:

2014-12-18 14:22:09,726 Trac[console] ERROR: Exception in trac-admin command: 
Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\admin\console.py", line 107, in onecmd
    rv = cmd.Cmd.onecmd(self, line) or 0
  File "C:\Python26\Lib\cmd.py", line 218, in onecmd
    return self.default(line)
  File "build\bdist.win32\egg\trac\admin\console.py", line 285, in default
    return self.cmd_mgr.execute_command(*args)
  File "build\bdist.win32\egg\trac\admin\api.py", line 127, in execute_command
    return f(*fargs)
  File "build\bdist.win32\egg\trac\versioncontrol\admin.py", line 96, in _do_changeset_added
    errors = rm.notify('changeset_added', reponame, revs)
  File "build\bdist.win32\egg\trac\versioncontrol\api.py", line 666, in notify
    if reponame in self.repository_sync_per_request:
AttributeError: 'RepositoryManager' object has no attribute 'repository_sync_per_request'

It seems to be related to #11756 and #11776:

In #11756 RepositoryManager.repository_sync_per_request gets used on 1.0-stable in [13337], merged to trunk in [13338].

In #11776 RepositoryManager.repository_sync_per_request gets incompletly removed on trunk in [13393]. The new usage remains and fails.

Attachments (0)

Change History (3)

comment:1 by Peter Suter, 5 years ago

Description: modified (diff)

comment:2 by Ryan J Ollos, 5 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: newclosed

Thanks, fixed in [13544].

I'd like to do something about the instances of repos.reponame or '(default)' all over the codebase, perhaps adding a repos.dispname attribute. I'll leave that for another day.

comment:3 by Ryan J Ollos, 5 years ago

Owner: set to Peter Suter

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Peter Suter.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Peter Suter to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.