Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#11880 closed defect (duplicate)

Reverse order of URL and localpath in svn_prop.py

Reported by: cabl@… Owned by:
Priority: normal Milestone:
Component: version control Version: 1.0-stable
Severity: major Keywords: svn15 svn:externals
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Jun Omae)

Dear experts,

I´m a beginner in Trac, so I´m sorry if my comment does not proceed.

When using Ubuntu 12, Trac 1.0.3 (just installed from repository) and SVN 1.8, I´ve found that my svn:externals are never proccessed, as local variable (in svn_prop.py) href is always empty. I think the order of localpath and url variables is reversed.

My svn externals, as gotten with svn command in shell, look like: URL LOCALPATH (e.g. https://server/SVN/Repo REPO_IN_LOCAL_COPY)

And my trac.ini [svn:externals] section, like:

dummykey = SVNURL TRACURL (e.g. repokey = https://server/SVN http://server/TRAC/browser/$path?rev=$rev)

I´ve changed localpath, rev, url = elments[0],'',elements[-1] in svn_prop.py to url, rev, localpath = elments[0],'',elements[-1] and now it´s working fine.

Am I missing anything? Do I have any missconfiguration issue?

BR

Attachments (0)

Change History (2)

comment:1 by Jun Omae, 5 years ago

Description: modified (diff)
Keywords: reverse order removed
Version: 1.0-stable

comment:2 by Jun Omae, 5 years ago

Keywords: svn15 added
Resolution: duplicate
Status: newclosed

A duplicate of #7687.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.