Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#1180 closed enhancement (duplicate)

Ticket comments should be editable by the admin

Reported by: mal@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.8
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

First of all : thank you for this great piece of software ! I really like the look & feel of it (having used cvstrac for more than a year now).

In v0.8 you can currently only add new comments of a ticket, but there's no way to edit an already added comment. I think it should be possible for an admin to edit existing comments and e.g. correct wording or formatting. It often happens that copy&paste from an email results in weird output in the ticket display - especially if the email contains code snippets.

Attachments (0)

Change History (6)

comment:1 by anonymous, 15 years ago

I want to second this. This is probably the only missing piece of functionality that prevents me from switching over to Trac. More specifically, I would expect: 1) Ability to edit the issue summary 2) Ability to edit the issue description 3) Ability to edit comments 4) As a consequence of the above, a log of changes to an issue would be required showing who made what changes to the issue, & when.

The reason why editing existing bugs is important to me is that very often, the initial assessment of a bug/feature is incorrect, and the summary/description of the issue needs to be modified to reflect the discussion that follows. Similarly, comments are sometimes incorrect or missing bits of information, and the thread is much more readable if users can edit existing entries instead of forcing new ones to unnecessarily be added.

Note: For an example of a decent implementation of this, check out Mantis (http://www.mantisbt.org/). Note: the demo on their site is currently out-of-date.

comment:2 by Florent Guillaume <fg@…>, 15 years ago

Cc: fg@… added

comment:3 by Matthew Good, 15 years ago

Summary: Ticket summaries should be editable by the adminTicket comments should be editable by the admin

Yes, I wish I could edit the above comment since Trac already supports most of what you're asking for ;)

Actually, the comment editing is the only part missing. Anyone who can comment on a ticket can change the summary (as I'm doing now) and admins can edit the ticket description. I think comment editing would be useful (mainly for fixing formatting errors from people forgetting to preview). I think that the initial support will be to allow admins to edit comments, though I believe that there has been discussion of how to allow users to go back and edit their own comments.

comment:4 by Christian Boos, 15 years ago

Resolution: duplicate
Status: newclosed

So, if that ticket boils down to editing ticket comments… this is a duplicate of #454

comment:5 by anonymous, 14 years ago

Cc: fg@… removed

comment:6 by 야한녀, 14 years ago

화끈한 공짜화상채팅, 고화질 캠사이트

http://baa.yy.to/

http://baa.yy.to/

http://baa.yy.to/

1:1 비밀대화방, 특별한 혜택과 서비스

다수의 이쁜여성과 자유로운 즉석 번개팅가능!

삭+제+번+호:err588 </a>

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.