Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11747 closed defect (duplicate)

MySQL error #1073 when creating tables with default-table-type=NDBCLUSTER

Reported by: slomotran-omc16@… Owned by:
Priority: normal Milestone:
Component: database backend Version: 1.0-stable
Severity: normal Keywords: mysql
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by anonymous)

Trace

Failed to create environment.
(1073, "BLOB column 'name' can't be used in key specification with the used tabl e type")
Traceback (most recent call last):
  File "C:\Python27\lib\site-packages\trac\admin\console.py", line 456, in do_in itenv options=options)
  File "C:\Python27\lib\site-packages\trac\core.py", line 124, in __call__ self.__init__(*args, **kwargs)
  File "C:\Python27\lib\site-packages\trac\env.py", line 281, in __init__ self.create(options)
  File "C:\Python27\lib\site-packages\trac\env.py", line 584, in create DatabaseManager(self).init_db()
  File "C:\Python27\lib\site-packages\trac\db\api.py", line 251, in init_db connector.init_db(**args)
  File "C:\Python27\lib\site-packages\trac\db\mysql_backend.py", line 119, in in it_db cursor.execute(stmt)
  File "C:\Python27\lib\site-packages\trac\db\util.py", line 66, in execute return self.cursor.execute(sql)
  File "C:\Python27\lib\site-packages\MySQLdb\cursors.py", line 205, in execute self.errorhandler(self, exc, value)
  File "C:\Python27\lib\site-packages\MySQLdb\connections.py", line 36, in defaulterrorhandler raise errorclass, errorvalue
OperationalError: (1073, "BLOB column 'name' can't be used in key specification with the used table type")

mysql.ini

[mysqld default] default-table-type=NDBCLUSTER

further information

http://forums.mysql.com/read.php?20,381076,381704#msg-381704

Attachments (0)

Change History (3)

comment:1 by anonymous, 8 years ago

Description: modified (diff)

comment:2 by Jun Omae, 8 years ago

Resolution: duplicate
Status: newclosed

A duplicate of #8567.

comment:3 by anonymous, 8 years ago

then someone should fix MySqlDb since trac does not support NDB out of the box

Last edited 8 years ago by Jun Omae (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.