Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#11621 closed defect (duplicate)

Unable to create trac environment

Reported by: amjad@… Owned by:
Priority: normal Milestone:
Component: general Version: 1.0.1
Severity: normal Keywords: babel10
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Jun Omae)

root@revision-control ~# trac-admin /var/local/trac initenv
Traceback (most recent call last):
  File "/usr/local/bin/trac-admin", line 9, in <module>
    load_entry_point('Trac==1.0.1', 'console_scripts', 'trac-admin')()
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/admin/console.py", line 567, in run
    translation.activate(locale)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/util/translation.py", line 325, in activate
    translations.activate(locale, env_path)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/util/translation.py", line 152, in activate
    t.add(Translations.load(locale_dir, locale or 'en_US',
AttributeError: 'NullTranslations' object has no attribute 'add'

Attachments (0)

Change History (1)

comment:1 by Jun Omae, 7 years ago

Description: modified (diff)
Keywords: babel10 added; environment removed
Resolution: duplicate
Status: newclosed
Version: 1.0.1

A duplicate of #10882, #11345 and #10903. If Trac 1.0.1 with Babel 1.x, the issue raises. Please downgrade to Babel 0.9.6. Also, it has been fixed in 1.0-stable branch.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.