Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11611 closed defect (duplicate)

NotImplementedError in Git repository log view with Revision Log Mode: Show only adds and deletes

Reported by: Ryan J Ollos Owned by:
Priority: normal Milestone:
Component: version control/log view Version: 1.1.1dev
Severity: normal Keywords: git
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Ryan J Ollos)

How to Reproduce

While doing a GET operation on /log/rjollos.git/tracopt/versioncontrol/git/git_fs.py, Trac issued an internal error.


Go to log/rjollos.git/tracopt/versioncontrol/git/git_fs.py. Set Revision Log Mode: Show only adds and deletes and press Update.


Request parameters:

{'action': u'stop_on_copy',
 'limit': u'100',
 'mode': u'path_history',
 'path': u'/rjollos.git/tracopt/versioncontrol/git/git_fs.py',
 'rev': u'53ac34cbdce80257a687a553bb59beae0253bc95',
 'sfp_email': u'',
 'sfph_mail': u'',
 'stop_rev': u''}

User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/31.0.1650.63 Chrome/31.0.1650.63 Safari/537.36

System Information

Trac 1.1.2dev-r12592
Babel 0.9.6
Docutils 0.8.1
Genshi 0.7dev-r1134 (without speedups)
GIT 1.7.10.4
Mercurial 2.2.2
mod_wsgi 3.3 (WSGIProcessGroup trac WSGIApplicationGroup %{GLOBAL})
psycopg2 2.4.5
Pygments 1.5
Python 2.7.3 (default, Mar 13 2014, 11:26:58)
[GCC 4.7.2]
pytz 2012c
setuptools 0.6
Subversion 1.6.17 (r1128011)
jQuery 1.8.3

Enabled Plugins

StatusFixer r6326
TracMercurial 1.0.0.3dev
TracSpamFilter 0.8.0dev-r11796
TracVote 0.1
TracWikiExtras 0.13.2dev-r11714
TranslatedPagesMacro 0.5

Python Traceback

Traceback (most recent call last):
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/Trac-1.1.2dev_r12592-py2.7.egg/trac/web/main.py", line 517, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/Trac-1.1.2dev_r12592-py2.7.egg/trac/web/main.py", line 221, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/Trac-1.1.2dev_r12592-py2.7.egg/trac/versioncontrol/web_ui/log.py", line 173, in process_request
    for old_path, old_rev, old_chg in history():
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/Trac-1.1.2dev_r12592-py2.7.egg/trac/versioncontrol/web_ui/log.py", line 125, in history
    for h in repos.get_path_history(path, rev):
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/Trac-1.1.2dev_r12592-py2.7.egg/trac/versioncontrol/api.py", line 944, in get_path_history
    raise NotImplementedError
NotImplementedError

Attachments (0)

Change History (3)

comment:1 by Ryan J Ollos, 8 years ago

Description: modified (diff)

comment:2 by Ryan J Ollos, 8 years ago

Resolution: duplicate
Status: newclosed

Sorry, duplicate of #9775. Somehow I didn't spot that when searching earlier.

comment:3 by Ryan J Ollos, 8 years ago

Milestone: next-stable-1.0.x

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.