Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#11557 closed defect (fixed)

RegressionTestTicket8247 rarely fails

Reported by: Jun Omae Owned by: Jun Omae
Priority: low Milestone: 0.12.6
Component: general Version: 1.0-stable
Severity: normal Keywords: test
Cc:
Release Notes:

Fix rare failure of RegressionTestTicket8247 due to that /usr/share/dict/words file has anonymous phrase.

API Changes:

Description

======================================================================
FAIL: Test for regression of http://trac.edgewall.org/ticket/8247
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/run/shm/7ba15dad71439be9da2cf429aeb45bc66df4588f/py26-postgres/trac/ticket/tests/functional.py", line 2027, in runTest
    tc.notfind('anonymous')
  File "/run/shm/7ba15dad71439be9da2cf429aeb45bc66df4588f/py26-postgres/trac/tests/functional/better_twill.py", line 234, in better_notfind
    raise twill.errors.TwillAssertionError(*args)
TwillAssertionError: ("match to 'anonymous'", '/run/shm/7ba15dad71439be9da2cf429aeb45bc66df4588f/py26-postgres/testenv/trac/log/RegressionTestTicket8247.html')

In RegressionTestTicket8247.html, "anonymous" phrase indeed is present.

                  <th><label for="field-description">Description:</label></th>
                  <td class="fullrow" colspan="3">
                    <fieldset>
                      <label for="field-description" id="field-description-help">You may use
                        <a tabindex="42" href="/wiki/WikiFormatting">WikiFormatting</a> here.</label>
                      <textarea id="field-description" name="field_description" class="wikitext trac-resizable" rows="10" cols="68">
aff2323c foreseeable proteins fishbowl multilingual conking.

aff234e4 gulley wording disquiet Flintstones sparsest rape impedimenta.  aff23714 indued mayday moveables anonymously pithiest legendary soloed Herrera tourism peppercorn futzes Gloucester Greensleeves.  aff2389a connotative gongs blasted.  aff23a34 Watteau hypotheses staffed.  aff23c28 feasible height juts inevitably villagers infinitesimal.

aff23dea shaping Huitzilopotchli parades appalling televisions vocalization.  aff23fac domesticates imbed Tarkington replies morbidly lamebrain cockerel Starkey rudeness.  aff241b4 bindings littlest medley whizzes telecommuted reputed exemplifying.

aff2434e peripheries jamb.

aff244de city adipose Brownie vividest.

aff246dc mortars Saxony detects shootouts scuffing dicier abruptness supersonic affordable rehabbing Bonhoeffer finished.  aff24862 mossy bisector Pollock wormiest.  aff249e8 sticklers etymology maroon addends dictum.</textarea>
                    </fieldset>
                  </td>

It seems the reason is that /usr/share/dict/words file has anonymous phrase.

$ grep anonymous /usr/share/dict/words
anonymous
anonymously

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Jun Omae

Milestone: next-minor-0.12.x0.12.6
Owner: set to Jun Omae
Status: newassigned

Proposed patch in the following. I'll push it later.

  • trac/ticket/tests/functional.py

    index 2f437bb..9168614 100755
    a b class RegressionTestTicket8247(FunctionalTwillTestCaseSetup):  
    14361436        tc.go(ticket_url)
    14371437        tc.find('<strong>Milestone</strong>[ \n\t]*<em>%s</em> deleted' % name)
    14381438        tc.find('Changed <a.*</a> ago by admin')
    1439         tc.notfind('anonymous')
     1439        tc.notfind('</a> ago by anonymous')
    14401440
    14411441
    14421442class RegressionTestTicket8861(FunctionalTwillTestCaseSetup):

comment:2 Changed 5 years ago by Jun Omae

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Committed in [12626] and merged in [12627-12628].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.