Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11521 closed defect (duplicate)

CSS-Data delay

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: 1.0.1
Severity: normal Keywords: setuptools
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Jun Omae)

I have installed the Wiki-Trac 1.0.1 several Times on the computers in my company. There is always problem when I open the wiki for the first time. The CSS-Data is loaded too late and the browser (Internet Explorer and it is a known problem with Internet Explorer) shows the Wiki Site for the first Time without a correct Format (without CSS). When I refresh the Site it will be correct. How can I solve this Problem? Solution for such problems is some Codes like:

function displayInPages(page_no) 
{ document.frmDisplayInPage.page_no.value = page_no; document.frmDisplayInPage.submit();
 }

Attachments (4)

first.PNG (70.7 KB ) - added by anonymous 6 years ago.
second.PNG (59.9 KB ) - added by anonymous 6 years ago.
third.PNG (62.7 KB ) - added by anonymous 6 years ago.
trac.log (28.2 KB ) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 by Jun Omae, 6 years ago

Description: modified (diff)
Resolution: cantfix
Status: newclosed

I confirmed no issues on http://trac.edgewall.org/demo-1.0/wiki with Internet Explorer. That's an InstallationIssue. Please ask on the mailing list or IRC channel.

comment:2 by anonymous, 6 years ago

Resolution: cantfix
Status: closedreopened

I have not found any answer to this problem. I attach now to this ticket some screenshots which show you how in the first time the trac-wiki is without any format (see: first.png). But after refreshing is this site with a correct Format (see: second.png). In another screenshot you can see, which data are send from the Wiki in the Windows server (see third.png). You can see that the css-data in the first call are send with delay but not in the second time.

by anonymous, 6 years ago

Attachment: first.PNG added

by anonymous, 6 years ago

Attachment: second.PNG added

by anonymous, 6 years ago

Attachment: third.PNG added

comment:3 by Jun Omae, 6 years ago

Could you please enable TracLogging with DEBUG level, reproduce it and check log/trac.log in your environment?

comment:4 by Jun Omae, 6 years ago

Component: generalweb frontend/tracd
Version: 1.0dev1.0.1

Also,

  • Are you using tracd?
  • What version of Internet Explorer are you using?

comment:5 by anonymous, 6 years ago

Yes I use tracd. My Browser is Windows Internet Explorer 9.

by anonymous, 6 years ago

Attachment: trac.log added

in reply to:  3 comment:6 by anonymous, 6 years ago

Replying to jomae:

Could you please enable TracLogging with DEBUG level, reproduce it and check log/trac.log in your environment?

In Attachment you will find the log/trac.log. Thanks

comment:7 by Jun Omae, 6 years ago

Your trac.log has no errors. But reproduced.

  1. Install Trac as egg file, not unzipped.
  2. Removed egg cache directory (%APPDATA%\Python-Eggs in Windows)
  3. Launch tracd
  4. Clear browser cache
  5. Access Trac wiki
2014-03-25 23:10:50,904 Trac[main] ERROR: Internal Server Error: 
Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\trac\web\chrome.py", line 605, in process_request
    in provider.get_htdocs_dirs() or []
  File "build\bdist.win32\egg\trac\web\chrome.py", line 619, in get_htdocs_dirs
    return [('common', pkg_resources.resource_filename('trac', 'htdocs')),
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 869, in resource_filename
    self, resource_name
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 1345, in get_resource_filename
    return self._extract_resource(manager, zip_path)
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 1352, in _extract_resource
    manager, os.path.join(zip_path, name)
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 1352, in _extract_resource
    manager, os.path.join(zip_path, name)
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 1352, in _extract_resource
    manager, os.path.join(zip_path, name)
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 1352, in _extract_resource
    manager, os.path.join(zip_path, name)
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 1370, in _extract_resource
    self.egg_name, self._parts(zip_path)
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 949, in get_cache_path
    self.extraction_error()
  File "C:\usr\apps\python25\lib\site-packages\distribute-0.6.14-py2.5.egg\pkg_resources.py", line 915, in extraction_error
    raise err
ExtractionError: Can't extract file(s) to egg cache

First request leads extracting egg files. Additional requests while extracting trac-1.0.1-py2.5.egg file lead the issue.

Work around is using --always-unzip option of easy_install to install as unzipped egg files.

$ easy_install.exe --always-unzip Trac-1.0.1-py2.5.egg

This issue is a duplicate of #9978 and #8537.

comment:8 by anonymous, 6 years ago

Some thing was rong.I have now another errore from tracd after installing Trac-1.0.1-py2.5.egg with easy_install.exe:

Traceback (most recent call last):
  File "C:\it-gf\wiki-trac-install\test_wiki\test_mit_tooll\Trac1.0.1\python25\scripts\tracd-script.py", line 8, in <mod
ule>
    load_entry_point('trac==1.0.1', 'console_scripts', 'tracd')()
  File "C:\it-gf\wiki-trac-install\test_wiki\test_mit_tooll\Trac1.0.1\python25\lib\site-packages\setuptools-0.6c11-py2.5
.egg\pkg_resources.py", line 318, in load_entry_point
  File "C:\it-gf\wiki-trac-install\test_wiki\test_mit_tooll\Trac1.0.1\python25\lib\site-packages\setuptools-0.6c11-py2.5
.egg\pkg_resources.py", line 2220, in load_entry_point
ImportError: Entry point ('console_scripts', 'tracd') not found

comment:9 by anonymous, 6 years ago

Can you tell me please in which directory the Python-Eggs should be saved? In my system this directory is completely separated from my trac-projects in completely another path. Can I define manually a new path for Python-Eggs? Isn’t it the reason for this problem?

in reply to:  8 comment:10 by Jun Omae, 6 years ago

Replying to anonymous:

Some thing was rong.I have now another errore from tracd after installing Trac-1.0.1-py2.5.egg with easy_install.exe:

Hmm, that's strange…. Please try to reinstall Trac.

C:> easy_install.exe --always-unzip Trac==1.0.1

Can I define manually a new path for Python-Eggs?

You may use PYTHON_EGG_CACHE environment variable. See TracInstall#SettingupthePluginCache.

Isn’t it the reason for this problem?

The issue is not depended on the directory location. Root cause is accessing static resources in egg files while extracting the eggs. The work around would prevent to extract the eggs by unzipped installation.

Last edited 6 years ago by Jun Omae (previous) (diff)

comment:11 by anonymous, 6 years ago

Resolution: fixed
Status: reopenedclosed

Thank you so much! The problem is solved!

comment:12 by Jun Omae, 6 years ago

Component: web frontend/tracdgeneral
Keywords: setuptools added; css removed
Resolution: fixedduplicate

Thanks for the feedback. Closing as a duplicate of #9978.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.