Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11434 closed enhancement (fixed)

Set component when reporting defects to trac-hacks

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 0.12.6
Component: general Version:
Severity: normal Keywords: error reporting trac-hacks
Cc:
Release Notes:

Component is set in the ticket when using semi-automated reporting to trac-hacks.org.

API Changes:

Description

It would be useful to have the Component set when creating bug reports to trac-hacks from the error.html page. The changes in log:rjollos.git:t11434 implement that change. See also th:#11479.

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by Ryan J Ollos

Status: newassigned

comment:2 Changed 5 years ago by Ryan J Ollos

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Committed to 0.12-stable in [12425], merged to 1.0-stable in [12426,12428] and merged to trunk in [12427,12429].

comment:3 Changed 5 years ago by Jun Omae

I got the following failure of functional tests with 0.12-stable and Python 2.4 on Windows.

======================================================================
FAIL: runTest (trac.tests.functional.testcases.RegressionTestTicket11434)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\usr\src\trac\trac.git\trac\tests\functional\testcases.py", line 234, in runTest
    tc.find('<form class="newticket" method="get" '
  File "C:\usr\src\trac\trac.git\trac\tests\functional\better_twill.py", line 189, in better_find
    raise twill.errors.TwillAssertionError(*args)
TwillAssertionError: ('no match to \'<form class="newticket" method="get" action="http://trac-hacks.org/newticket">\'', 'C:\\usr\\src\\trac\\trac.git\\testenv\\trac\\log\\RegressionTestTicket11434.html')

----------------------------------------------------------------------
Ran 114 tests in 224.375s

FAILED (failures=1)

It seems match_plugins_to_frames cannot find the frame of plugins/RaiseExceptionPlugin.py on Windows. The issue is the same as comment:18:ticket:5516. See also [9028].

  • trac/loader.py

    diff --git a/trac/loader.py b/trac/loader.py
    index 1c4956b..4ec19a5 100644
    a b def match_plugins_to_frames(plugins, frames):  
    239239                pass    # Metadata not found
    240240
    241241    for plugin in plugins:
    242         base, ext = os.path.splitext(plugin['path'])
     242        base, ext = os.path.splitext(plugin['path'].replace('\\', '/'))
    243243        if ext == '.egg' and egg_frames:
    244244            find_egg_frame_index(plugin)
    245245        else:

comment:4 Changed 5 years ago by Jun Omae

Committed the patch to 0.12-stable in [12445] and merged in [12446,12447].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.