Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#1140 closed defect (fixed)

trac internal error: ('Unable to open root of edit', 220000)

Reported by: aschultz@… Owned by: Matthew Good
Priority: normal Milestone: 0.9
Component: version control/changeset view Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

After upgrading from 0.8 to svn snapshot 1197 i get an internal error when trying to view a changeset. The full trace is:

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 533, in cgi_start
    real_cgi_start()
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 528, in real_cgi_start
    dispatch_request(path_info, args, req, env)
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 443, in dispatch_request
    module.run()
  File "/usr/lib/python2.3/site-packages/trac/Module.py", line 45, in run
    disp()
  File "/usr/lib/python2.3/site-packages/trac/Changeset.py", line 445, in display
    self.render_diffs()
  File "/usr/lib/python2.3/site-packages/trac/Changeset.py", line 441, in render_diffs
    0, 1, 0, 1, self.pool)
SubversionException: ('Unable to open root of edit', 220000)

Attachments (0)

Change History (4)

comment:1 by aschultz@…, 15 years ago

Severity: blockernormal

found the cruelprint. I've added authz directives to my trac.ini like this:

authz_file = /etc/subversion/dav_svn.authz
authz_module_name = test

But my dav_svn.authz did only contain a line like:

[/]
* = rw

Chaning this to:

[test:/]
* = rw

make the problem go away.

So the problem is that the authz module is unable to match the generic / rule to the module specific rule.

I'm not sure if this behaivior is desired, but the error message should at least clearly indicate that i don't have permissions to access this changeset instead of the cryptic error message one gets at the moment.

comment:2 by Christopher Lenz, 15 years ago

Component: generalchangeset view

comment:3 by Christopher Lenz, 14 years ago

Owner: changed from Jonas Borgström to Matthew Good

Matt, can you check whether this is still true with the improved authz support?

comment:4 by Matthew Good, 14 years ago

Milestone: 0.9
Resolution: fixed
Status: newclosed

Yeah, this was fixed with [1450] as well. The test suite includes checks for this scenario in the "Module Usage" section.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.