Edgewall Software
Modify

Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#11387 closed defect (duplicate)

trac.edgewall.org mainmenu blurred

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords: layout
Cc: Ryan J Ollos Branch:
Release Notes:
API Changes:

Description

sometimes (latest) Firefox shows this blurred selected menu item text

Attachments (1)

blurred.PNG (4.9 KB ) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (14)

by anonymous, 6 years ago

Attachment: blurred.PNG added

comment:1 by Ryan J Ollos, 6 years ago

Cc: Ryan J Ollos added
Milestone: next-stable-1.0.x

I've noticed this as well on one of my Trac sites.

comment:2 by Jun Omae, 6 years ago

Firefox for Windows works fine. I guess the issue is reproduced with only Firefox on Linux (using GTK?). That seems it caused by text-shadow: 1px 0 #eee in [11132].

comment:3 by fbrettschneider@…, 6 years ago

I see it on Windows FF, too

comment:4 by anonymous, 5 years ago

I see it on Windows Firefox and Chrome when the browser's zoom setting is changed to certain levels. Setting text-shadow to 0.06em instead of 1px seems to fix this.

comment:5 by Christian Boos, 5 years ago

Keywords: layout added
Milestone: next-stable-1.0.x1.0.4
Owner: set to Christian Boos
Status: newassigned

IIRC, I also used 0.06em at one point in my tests, so I think this make for an acceptable workaround.

As a reminder, the reason why I used the text-shadow trick instead of simply bold is that the former doesn't change the overall width of the text, while the latter does and this changes the layout of the navigation bar while hovering.

comment:6 by Ryan J Ollos, 5 years ago

Milestone: 1.0.41.0.5

comment:7 by Ryan J Ollos, 5 years ago

Milestone: 1.0.51.0.6

comment:8 by Ryan J Ollos, 4 years ago

Milestone: 1.0.61.0.7

comment:9 by Ryan J Ollos, 4 years ago

Milestone: 1.0.7next-stable-1.0.x

comment:10 by Ryan J Ollos, 4 years ago

Owner: Christian Boos removed
Status: assignednew

comment:11 by Ryan J Ollos, 3 years ago

Milestone: next-stable-1.0.xnext-stable-1.2.x

Moved ticket assigned to next-stable-1.0.x since maintenance of 1.0.x is coming to a close. Please move the ticket back if it's critical to fix on 1.0.x.

comment:12 by Ryan J Ollos, 3 years ago

Milestone: next-stable-1.2.x
Resolution: duplicate
Status: newclosed

#633 changes the fonts from pixels to em, so closing as a duplicate of that ticket.

comment:13 by Christian Boos, 3 years ago

Actually, it's just that in the wiki-restyling branch (#12640) I no longer try to make the text of the selected tab appear bolder, using text-shadow or otherwise.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.