Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#11376 closed defect (fixed)

Ticket description textarea doesn't wrap on whitespace in IE11

Reported by: Ryan J Ollos Owned by: Jun Omae
Priority: normal Milestone: 0.12.6
Component: ticket system Version:
Severity: normal Keywords: iexplorer11
Cc:
Release Notes:

Fix not wrapping the text inside ticket description textarea in IE 11

API Changes:

Description (last modified by Ryan J Ollos)

In IE11, the text inside the ticket description textarea doesn't wrap on whitespace.

The issue was raised on the mailing list.

Attachments (1)

TicketDescriptionTextAreaInIE11.png (12.0 KB ) - added by Ryan J Ollos 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by Ryan J Ollos

comment:1 Changed 5 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 5 years ago by Jun Omae

Keywords: iexplorer11 added

In IE11, the textarea in <fieldset id="properties"> refers #properties { white-space: nowrap; ... } in ticket.css. It's not known why….

Workaround is here.

  • trac/htdocs/css/ticket.css

    diff --git a/trac/htdocs/css/ticket.css b/trac/htdocs/css/ticket.css
    index 7e18e20..5f873c1 100644
    a b form .field div.trac-resizable { width: 100% }  
    214214
    215215#propertyform { margin-bottom: 2em; }
    216216#properties { white-space: nowrap; line-height: 160%; padding: .5em }
     217#properties textarea { white-space: pre-wrap }
    217218#properties table { border-spacing: 0; width: 100%; padding: 0 .5em }
    218219#properties table th {
    219220 padding: .4em;

Or removing white-space: nowrap in #properties, but I don't understand need of the nowrap.

comment:3 in reply to:  2 Changed 5 years ago by ilewismsl

Replying to jomae:

Workaround is here.

Confirmed workaround by adding:

textarea { white-space: pre-wrap; }

to local site css.

comment:4 in reply to:  2 Changed 5 years ago by Ryan J Ollos

Milestone: next-stable-1.0.x1.0.2

Replying to jomae:

Or removing white-space: nowrap in #properties, but I don't understand need of the nowrap.

I don't understand why it is needed either. The rule can be traced all the back to [280#file1], so it seems rather likely that it has no purpose and still exists because it failed to cause any issues until now.

comment:5 Changed 5 years ago by Ryan J Ollos

… or maybe we should fix it for 0.12.6 as well?

comment:6 in reply to:  5 Changed 5 years ago by Jun Omae

Milestone: 1.0.20.12.6

… or maybe we should fix it for 0.12.6 as well?

Yeah, we should fix for 0.12.6.

comment:7 Changed 5 years ago by Jun Omae

Owner: set to Jun Omae
Status: newassigned

I've verified the patch in comment:3 with Firefox 26, Google Chrome 32 beta and IE 8-11. It would be fixed the same issue even if a plugin use white-space: nowrap in other places.

  • trac/htdocs/css/trac.css

     
    6868
    6969/* Forms */
    7070input, textarea, select { margin: 2px }
     71/* Avoid to inherit white-space of its parent element for IE 11, #11376 */
     72textarea { white-space: pre-wrap }
    7173input, select { vertical-align: middle }
    7274input[type=button], input[type=submit], input[type=reset] {
    7375 background: #eee;

comment:8 Changed 5 years ago by Jun Omae

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Applied into 0.12-stable and merged into 1.0-stable and trunk in [12334-12336].

comment:9 Changed 4 years ago by Ryan J Ollos

Component: generalticket system

comment:10 Changed 2 years ago by anonymous

Thank You! This is nice. I've only seen the resolution to this page.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.