Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#11336 closed enhancement (fixed)

Hide the retarget select when the milestone has no associated tickets

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.1.2
Component: roadmap Version:
Severity: normal Keywords: milestone retarget
Cc: Branch:
Release Notes:

When editing or deleting a milestone and there are no tickets associated with the milestone, the retarget elements are not shown and a hint is shown in their place.

API Changes:

Description

It was previously discussed starting in comment:38:ticket:5658 that the retarget select should be hidden when there are no retargetable tickets associated with the milestone. This applies to the Milestone edit page and the Milestone delete page. For the Milestone edit action, any open tickets are retargetable. For the Milestone delete action, any tickets associated with the milestone are retargetable.

Attachments (9)

DeleteMilestone1.png (11.1 KB ) - added by Ryan J Ollos 6 years ago.
DeleteMilestone2.png (8.6 KB ) - added by Ryan J Ollos 6 years ago.
DeleteMilestone2WithHint.png (10.8 KB ) - added by Ryan J Ollos 6 years ago.
EditMilestone3.png (18.7 KB ) - added by Ryan J Ollos 6 years ago.
EditMilestone4.png (14.5 KB ) - added by Ryan J Ollos 6 years ago.
EditMilestone6.png (20.4 KB ) - added by Ryan J Ollos 5 years ago.
t11336-revision.patch (1.5 KB ) - added by Ryan J Ollos 5 years ago.
t11336-revision2.patch (2.1 KB ) - added by Ryan J Ollos 5 years ago.
DeleteMilestone3.png (10.9 KB ) - added by Ryan J Ollos 5 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 by Ryan J Ollos, 6 years ago

Status: newassigned

by Ryan J Ollos, 6 years ago

Attachment: DeleteMilestone1.png added

by Ryan J Ollos, 6 years ago

Attachment: DeleteMilestone2.png added

by Ryan J Ollos, 6 years ago

by Ryan J Ollos, 6 years ago

Attachment: EditMilestone3.png added

by Ryan J Ollos, 6 years ago

Attachment: EditMilestone4.png added

comment:2 by Ryan J Ollos, 6 years ago

When I started working this ticket, I was thinking that it might not be very good practice to have elements conditionally appear on the form, as comment:description suggests should be implemented. However, that is what we are currently doing for the case that there are no milestones to which the tickets can be retargeted: tags/trac-1.0.1/trac/ticket/templates/milestone_edit.html@:82#L71. That behavior is also undesirable because the user doesn't have a choice to retarget the tickets to None vs leaving them associated with the milestone that is being closed.

I experimented with the idea of always showing the retarget elements when there are tickets associated with the milestone, even when the only choice in the selet is to retarget the tickets to the None milestone, and showing a hint when there are no tickets associated with the milestone.

Here are some screen captures. The associated changes can be found in log:rjollos.git:t11336. What do you think about replacing the retarget form elements with a hint?

Milestone delete: Tickets associated with the milestone

Milestone delete: Tickets associated with the milestone (no hint)

Milestone delete: Tickets associated with the milestone (hint)

Milestone edit: Tickets associated with the milestone

Milestone edit: Tickets associated with the milestone

comment:3 by Ryan J Ollos, 6 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Committed to trunk in [12215:12217].

comment:4 by Ryan J Ollos, 6 years ago

Release Notes: modified (diff)

comment:5 by Ryan J Ollos, 5 years ago

I've introduced a regression in that the New Milestone form shows the retarget select. The proposed fix can be found in log:rjollos.git:t11336.2.

comment:6 by Ryan J Ollos, 5 years ago

Fix from comment:5 committed to trunk in [12301:12302].

by Ryan J Ollos, 5 years ago

Attachment: EditMilestone6.png added

by Ryan J Ollos, 5 years ago

Attachment: t11336-revision.patch added

comment:7 by Ryan J Ollos, 5 years ago

I haven't been too happy with the styling of the text shown in comment:2 for There are no tickets associated with this milestone. It looks out of place. Maybe this is better (t11336-revision.patch)?

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

by Ryan J Ollos, 5 years ago

Attachment: t11336-revision2.patch added

comment:8 by Ryan J Ollos, 5 years ago

Patch that includes changes to the delete confirmation page: t11336-revision2.patch.

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

by Ryan J Ollos, 5 years ago

Attachment: DeleteMilestone3.png added

in reply to:  7 comment:9 by Jun Omae, 5 years ago

Replying to rjollos:

I haven't been too happy with the styling of the text shown in comment:2 for There are no tickets associated with this milestone.. It looks out of place. Maybe this is better (t11336-revision.patch)?

Looks good to me. I like help styled text rather than italic.

comment:10 by Ryan J Ollos, 5 years ago

Release Notes: modified (diff)

Thanks for reviewing. Committed to trunk in [12539].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.