Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

#11325 closed defect (worksforme)

wrong version sorting

Reported by: kubes@… Owned by:
Priority: normal Milestone:
Component: general Version: 1.0-stable
Severity: normal Keywords: version order
Cc: Ryan J Ollos
Release Notes:
API Changes:

Description (last modified by kubes@…)

The following bug should reopen #1064 plus it involves the milestone report ordered by version (../milestone/mymilestone?by=version).

Because of the wrong order of version, the version histogram is not sorted corretly and that is why, it cannot show the bug ratio in time.

Alphabetical order is not enough for version, because version has it own specific sort order see http://stackoverflow.com/questions/2574080/sorting-a-list-of-version-strings

For example:

alphabetical:

  • 2.18.1
  • 2.8.7
  • 2.9.1

correct:

  • 2.8.7
  • 2.9.1
  • 2.18.1

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by kubes@…

Description: modified (diff)

comment:2 Changed 4 years ago by Ryan J Ollos

Versions are sorted descending by their release date, and versions with no release date are presented first. Therefore, the change you suggest would only apply to versions with no release date. Is that part clear to you? Given that, I think that sorting the versions with no release date as you suggest makes sense.

Regarding #1064, generally I don't like to reopen tickets that are associated with a previous release, and this ticket is a refinement that was not discussed in #1064 (as opposed to a regression or defect that was intended to be fixed, but not fixed in the ticket), so I don't see a reason to reopen #1064.

Last edited 4 years ago by Ryan J Ollos (previous) (diff)

comment:3 Changed 4 years ago by Ryan J Ollos

Cc: Ryan J Ollos added

I took a closer look. The versions are sorted descending, and some reasons for this are given in #1064. Therefore, the correct sorting would be:

  • 2.18.1
  • 2.9.1
  • 2.8.7

Versions that don't have a release date are sorted in this order. The sort function is the same as the one shown in SO:2574080. If your versions are not sorting in this order, it is most likely because they have release dates that correspond to the order you are seeing.

comment:4 Changed 4 years ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.