Edgewall Software
Modify

Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#11319 closed defect (fixed)

Raising UnicodeEncodeError with unicode text for session key in prefs/advanced page

Reported by: Jun Omae Owned by: Jun Omae
Priority: low Milestone: 1.0.7
Component: general Version: 0.12-stable
Severity: normal Keywords: preferences
Cc: Branch:
Release Notes:

Fix raising UnicodeEncodeError when unicode characters are used in new session id and session id to restore on prefs/advanced page.

API Changes:
Internal Changes:

Description

If submitting unicode text for session key in prefs/advanced page, UnicodeEncodeError will be raised. I think that the session key should be only ascii characters.

This issue has been originally reported in babel:#332.

Attachments (0)

Change History (11)

comment:1 by Jun Omae, 6 years ago

Keywords: preferences added

comment:2 by Jun Omae, 6 years ago

Milestone: next-stable-1.0.x1.0.3
Owner: set to Jun Omae
Status: newassigned

Proposed changes in jomae.git@t11319. After the changes, only alphanumeric characters is used for new session key. Because the new session key for anonymous will be used in cookie, I think we should add the limitation.

comment:3 by Jun Omae, 6 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Committed in [13397] and merged to trunk in [13398].

comment:4 by Ryan J Ollos, 5 years ago

Similar issue reported in th:#12421 and confirmed with Trac 1.0.6. Use of unicode character in session key when restoring session results in UnicodeEncodeError.

comment:5 by Jun Omae, 5 years ago

Milestone: 1.0.31.0.7
Resolution: fixed
Status: closedreopened

Hmm. It seems to be not fixed…. I'll fix it again. We should add functional tests also.

comment:6 by Jun Omae, 5 years ago

Proposed changes in jomae.git@t11319.2 in restore session with unicode characters for session id.

comment:7 by Jun Omae, 5 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: reopenedclosed

Fixed in [14120:14121] again.

comment:8 by anonymous, 5 years ago

What happens with non-anymous username accounts that have e.g. dashes in their username (e.g. "the-duke")? I've noticed some users can't log in anymore and get a Trac error instead now after upgrading to Trac 1.0.7

comment:9 by ebray, 4 years ago

Ditto to the last commenter. This change was too restrictive—I have users whose usernames contain . for example.

comment:10 by Ryan J Ollos, 4 years ago

The issues mentioned in comment:8 and comment:9 shouldn't be seen after 1.0.8, see #12129.

in reply to:  10 comment:11 by ebray, 4 years ago

Replying to Ryan J Ollos:

The issues mentioned in comment:8 and comment:9 shouldn't be seen after 1.0.8, see #12129.

Just saw this comment finally—I kept meaning to open an ticket for this but see it's already been resolved. I understand now this was only meant to apply to SIDs and not usernames. Thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.