Edgewall Software

Opened 5 years ago

Closed 4 years ago

#11281 closed defect (duplicate)

AttributeError: NullTranslationsBabel instance has no attribute 'isactive'

Reported by: sandino Owned by:
Priority: normal Milestone:
Component: general Version: 1.0.1
Severity: normal Keywords:
Release Notes:
API Changes:


How to Reproduce

While doing a GET operation on /admin, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': None, 'panel_id': None, 'path_info': None}

User agent: Opera/9.80 (Windows NT 6.2; Win64; x64; MRA 5.7 (build 03797)) Presto/2.12.388 Version/12.16

System Information

Trac 1.0.1
Babel 1.0dev-r661 (translations unavailable)
Docutils 0.11
Genshi 0.7 (with speedups)
Pygments 1.6
pysqlite 2.6.0
Python 2.7.3 (default, Apr 10 2013, 05:46:21)
[GCC 4.6.3]
pytz 2013b
setuptools 0.6c11
SQLite 3.7.9
jQuery 1.7.2

Enabled Plugins

TracAccountManager 0.4.3

Python Traceback

Traceback (most recent call last):
  File "/home/django/trac/venv/local/lib/python2.7/site-packages/trac/web/main.py", line 497, in _dispatch_request
  File "/home/django/trac/venv/local/lib/python2.7/site-packages/trac/web/main.py", line 179, in dispatch
  File "/home/django/trac/venv/local/lib/python2.7/site-packages/trac/web/main.py", line 325, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/home/django/trac/venv/local/lib/python2.7/site-packages/trac/versioncontrol/api.py", line 340, in pre_process_request
    if is_default(reponame):
  File "/home/django/trac/venv/local/lib/python2.7/site-packages/trac/versioncontrol/api.py", line 34, in is_default
    return not reponame or reponame in ('(default)', _('(default)'))
  File "/home/django/trac/venv/local/lib/python2.7/site-packages/trac/util/translation.py", line 195, in gettext
    return safefmt(self.active.ugettext(string), kwargs)
  File "/home/django/trac/venv/local/lib/python2.7/site-packages/trac/util/translation.py", line 190, in __getattr__
    def __getattr__(self, name):
AttributeError: NullTranslationsBabel instance has no attribute 'isactive'

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #10903. Please use Babel 0.9.6.

comment:2 Changed 4 years ago by lm@…

Resolution: duplicate
Status: closedreopened

I still have this problem - cannot enable account manager.

Trac 1.0.1 with patch from ticket:10903#comment:4 applied.
Babel 1.3.

comment:3 Changed 4 years ago by Jun Omae

Resolution: duplicate
Status: reopenedclosed

See #11345.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment

E-mail address and name can be saved in the Preferences .
Note: See TracTickets for help on using tickets.