Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11276 closed defect (duplicate)

MySQL: primary key length with utf8mb4

Reported by: belousov.roman@… Owned by:
Priority: normal Milestone:
Component: database backend Version: 0.12.2
Severity: normal Keywords: mysql utf8mb4
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Ryan J Ollos)

Similarly to #3676, the error (1071, 'Specified key was too long; max key length is 767 bytes') appears when initializing a project. Differently from the mentioned case I tried to use utf8mb4 encoding of my database. The suggested quick fix didn't work, I assume for the encoding. However changing to utf8 encoding resolved the problem.

Attachments (0)

Change History (2)

comment:1 by Jun Omae, 6 years ago

Keywords: max key length removed
Resolution: duplicate
Status: newclosed
Version: 0.12-stable0.12.2

A duplicate of #9766. Try to upgrade to 0.12.3 or later.

comment:2 by Ryan J Ollos, 4 years ago

Description: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.