Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1124 closed defect (invalid)

Long links spill out past the box in the changelog for a ticket in Firefox

Reported by: anonymous Owned by: Jonas Borgström
Priority: lowest Milestone:
Component: ticket system Version: 0.8
Severity: trivial Keywords: layout
Cc: jmberghold@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Placing a long link in a ticket comment, such as http://www.microsoft.com/downloads/details.aspx?FamilyID=a63cf496-f5d6-4e42-8276-5d1f3b1487d6&DisplayLang=en causes it to spill out past the edge of the box in the changelog for that ticket.

This problem was experienced in Firefox on Windows. However, it was fine in IE.

Attachments (0)

Change History (4)

comment:1 by anonymous, 16 years ago

Looks like the problem applies to the yellow ticket box too.

Again the problem is in Firefox, and not IE.

Here's the link again, so you can see it in the changelog: http://www.microsoft.com/downloads/details.aspx?FamilyID=a63cf496-f5d6-4e42-8276-5d1f3b1487d6&DisplayLang=en

comment:2 by Christopher Lenz, 16 years ago

Keywords: layout added; spill extend link changelog firefox removed
Priority: normallowest

Well, what would you suggest should happen in such cases?

comment:3 by Matthew Good <trac@…>, 16 years ago

Resolution: invalid
Status: newclosed

It appears that IE allows the link text to wrap at the '-' characters in this particular url. Interestingly enough, if you put a long url with no '-' characters that would allow it to wrap, IE simply expands the size of the box to fit the url, which is completely wrong.

In any case, this line-wrapping behavior is up to the browser and can't be controlled by Trac, so I'm going to close this.

comment:4 by anonymous, 16 years ago

The boxes could be set to scroll clipping, which would keep the link contained, at the expense of having a little box with scroll bars.

I thought I saw trac doing this elsewhere…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.