Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

#11215 closed defect (fixed)

Internal Error GET: /log/ilp/ when anonymous

Reported by: ikus060@… Owned by: Jun Omae
Priority: normal Milestone: 1.0.2
Component: plugin/git Version: 0.12.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:

fixed an internal error on log view for git repository if no LOG_VIEW permission.

API Changes:
Internal Changes:

Description

Browsing /log/ when not authenticated generate an internal exception in the Git library:

2013-06-21 06:10:50,552 Trac[main] ERROR: Internal Server Error: 
Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.2-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.2-py2.6.egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.2-py2.6.egg/trac/versioncontrol/web_ui/log.py", line 197, in process_request
    if repos.rev_older_than(stop_rev, node.created_rev):
  File "/usr/local/lib/python2.6/dist-packages/TracGit-0.12.0.5dev-py2.6.egg/tracext/git/git_fs.py", line 449, in rev_older_than
    rc = self.git.rev_is_anchestor_of(rev1, rev2)
  File "/usr/local/lib/python2.6/dist-packages/TracGit-0.12.0.5dev-py2.6.egg/tracext/git/PyGIT.py", line 789, in rev_is_anchestor_of
    rev1 = rev1.strip()
AttributeError: 'NoneType' object has no attribute 'strip'

You may browse to http://patrikdufresne.com/common/log/ilp/ When authenticated, their isn't any exception. The problem is reproducible for every Git repository. I've double check the permission, anonymous has LOG_VIEW permission.

Ubuntu 10.04.4 LTS Python 2.6.5

Attachments (0)

Change History (3)

comment:1 by Jun Omae, 8 years ago

Component: version control/log viewplugin/git
Keywords: git rev_is_anchestor_of strip log removed
Milestone: 1.0.2

Good catch! The Git support in Trac 1.0 has the same issue. However, git-plugin for Trac 0.12.x is not maintained here.

comment:2 by Jun Omae, 8 years ago

Owner: set to Jun Omae
Status: newassigned

comment:3 by Jun Omae, 8 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Fixed in [11833] and merged to trunk in [11834].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.