Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11190 closed enhancement (worksforme)

missing link to ticket/comment in the sent notification email

Reported by: butkovic@… Owned by:
Priority: normal Milestone:
Component: notification Version: 1.0.1
Severity: normal Keywords: email
Cc: ryan.j.ollos@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

yesterday, after reporting tickets at trac hacks, I've noticed, there is no http link included in the e-mail text. What makes my life quite difficult, as somehow I had to figure it out myself, to see the comment sent in the context of the whole bug.

I think, link to bug (possibly also to comment) should be included either in the upper or lower part of the e-mail to make it easily accessible directly from the recieved e-mail.

Attachments (0)

Change History (3)

comment:1 by Ryan J Ollos <ryan.j.ollos@…>, 10 years ago

Cc: ryan.j.ollos@… added

Trac notifications do include a link to the comment, at least in recent versions of Trac. You should see a link to the comment when you receive this email.

I believe the problem is that trac-hacks is still running Trac 0.10.6, which did not include a link to the comment. This is a rather sad state, but I haven't found enough time to complete the upgrade yet.

comment:2 by Christian Boos, 10 years ago

Resolution: worksforme
Status: newclosed

Also, the link could be missing or incomplete if you forgot to set [trac] base_url and [project] url. But other than that, it should work as expected.

Last edited 10 years ago by Christian Boos (previous) (diff)

comment:3 by Ryan J Ollos <ryan.j.ollos@…>, 10 years ago

I take back what I said about trac-hacks. I had confused the notifications received from trac-hacks with an issue that existed in the th:AnnouncerPlugin. Notifications from trac-hacks do include a link to the originating comment at the bottom of the email. I have noticed that in Gmail, the URL to the comment is often or always (by default) initially hidden in collapsed content. Clicking on the [...] expands to reveal the URL and rest of the email footer.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.