Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#11188 closed defect (duplicate)

AttributeError: NullTranslationsBabel instance has no attribute 'isactive'

Reported by: godblessyouamen@… Owned by:
Priority: normal Milestone:
Component: general Version: 1.0
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on , Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

System Information

Trac 1.0
Babel 1.0dev-r661
Docutils 0.10
Genshi 0.7 (without speedups)
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
Pygments 1.6
pysqlite 2.6.0
Python 2.7.1 (r271:86832, Nov 27 2010, 18:30:46) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.6.21
Subversion 1.6.15 (r1038135)
jQuery 1.7.2

Enabled Plugins

Python Traceback

Traceback (most recent call last):
  File "c:\users\admini~1\appdata\local\temp\easy_install-lb11or\Trac-1.0-py2.7-win32.egg.tmp\trac\web\main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\users\admini~1\appdata\local\temp\easy_install-lb11or\Trac-1.0-py2.7-win32.egg.tmp\trac\web\main.py", line 179, in dispatch
    chosen_handler)
  File "c:\users\admini~1\appdata\local\temp\easy_install-lb11or\Trac-1.0-py2.7-win32.egg.tmp\trac\web\main.py", line 325, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "c:\users\admini~1\appdata\local\temp\easy_install-lb11or\Trac-1.0-py2.7-win32.egg.tmp\trac\versioncontrol\api.py", line 340, in pre_process_request
    if is_default(reponame):
  File "c:\users\admini~1\appdata\local\temp\easy_install-lb11or\Trac-1.0-py2.7-win32.egg.tmp\trac\versioncontrol\api.py", line 34, in is_default
    return not reponame or reponame in ('(default)', _('(default)'))
  File "c:\users\admini~1\appdata\local\temp\easy_install-lb11or\Trac-1.0-py2.7-win32.egg.tmp\trac\util\translation.py", line 195, in gettext
    if not self.isactive:
  File "c:\users\admini~1\appdata\local\temp\easy_install-lb11or\Trac-1.0-py2.7-win32.egg.tmp\trac\util\translation.py", line 190, in __getattr__
    return getattr(self.active, name)
AttributeError: NullTranslationsBabel instance has no attribute 'isactive'

Attachments (0)

Change History (1)

comment:1 by Jun Omae, 10 years ago

Resolution: duplicate
Status: newclosed

A duplicate of #10903.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.