Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

#11153 closed defect (worksforme)

SMTP - Errors on sending mails since second project

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: notification Version: 1.0-stable
Severity: normal Keywords: SMTP, multiple projects
Cc: Darklink2000@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by anonymous)

I get the error after modifying a ticket or after creation of a user with the AccountManagerPlugin that the SMTP Connection unexpectedly was closed.
I will try to give you guys as many info that I can give.

I have this issue since I backed up a project to a backup folder and coppied this backuped folder as a new project folder so that I now have 2 projects. (Because the main structures of the wiki and so on fits very well into the other project - so I thought only change the required values)
Than I executed
tracd --port 8000 ./project1 ./project2
On the site I then had a info that I should run trac-admin /<pathTo>/project2 upgrade.
I did that and than got the message that it would be better to upgrade the wiki content to… did it, too.
Than I reconfigured the trac.ini of project2 like the one of project1 but modifyied some values as I need them for project2 of course (for example [project] settings and some other but not the SMTP settings except that I changed smtp_always_bcc to other email adresses).
I should say that before having project2 the notifications worked with my notification settings but since the second project none of the 2 projects have working notifications.

My [notification] settings:

admit_domains = 
always_notify_owner = true
always_notify_reporter = false
always_notify_updater = true
ambiguous_char_width = single
batch_subject_template = $prefix Batch modify: $tickets_descr
email_sender = SmtpEmailSender
ignore_domains = 
mime_encoding = none
sendmail_path = sendmail
smtp_always_bcc = email1@domain.de, email2@domain.de
smtp_always_cc = 
smtp_default_domain =
smtp_enabled = true
smtp_from = projects@MyDomain.de
smtp_from_author = false
smtp_from_name = ProjectName2
smtp_password = examplePW
smtp_port = 587
smtp_replyto = projects@myDomain.de
smtp_server = smtp.live.com
smtp_subject_prefix = __default__
smtp_user = projects@myDomain.de
ticket_subject_template = $prefix #$ticket.id: $summary
use_public_cc = false
use_short_addr = false
use_tls = true


Additional stuff:
I don't think that the AccountManagerPlugin has to do something with it because if I turn of the notification settings of the plugin I can create users successfuly again but the ticket modify notifications are still in problem than…

Attachments (0)

Change History (6)

comment:1 by anonymous, 7 years ago

Description: modified (diff)

comment:2 by Jun Omae, 7 years ago

Keywords: needinfo added

Can you give us the more details about the error in your logs?

Could you also try disabling all your plugins and try to reproduce the issue?

comment:3 by anonymous, 7 years ago

IP - - [17/Apr/2013 12:43:19] "POST /project2/ticket/1 HTTP/1.1" 303 -
IP - - [17/Apr/2013 12:43:16] "POST /project2/ticket/1 HTTP/1.1" 200 -

Such entries are in the server log after modifying a ticket. What does the 303 code mean?

I also disabled all extern plugins now and stoped one of the projects. But the error still appear. But why was is previously working fine all the time :-/

(I don't know if it is important but maybee the info helps: I run the server in GNU Screen and without my own apache)

And i noticed that SOMETIMES (seldom) the notification mails are sent too since cloning the prokect. Because I tested it without external plugins and in worked… To be sure I tested it again and the second time (and many other times later… ) it failed all the time again.

in reply to:  3 comment:4 by Jun Omae, 7 years ago

Such entries are in the server log after modifying a ticket.

Well…. Could you please check the trac.log in your Trac Environment? Not web server's log.

If the trac.log is missing, see wiki:TracLogging and try to enable logging and reproduce again. Tell us the details (e.g. stacktrace, name, message, etc…) of the exception.

If the exception is just a connection error, that is an InstallationIssue, not a Trac issue.

What does the 303 code mean?

See http://en.wikipedia.org/wiki/HTTP_303. That is no problem.

comment:5 by anonymous, 7 years ago

trac.log:

2013-04-17 19:55:05,458 Trac[web_ui] ERROR: Failure sending notification on change to 
ticket #1: SMTPServerDisconnected: Connection unexpectedly closed

Only that does appear in the log.
So it should be no bug?

comment:6 by Jun Omae, 7 years ago

Keywords: needinfo removed
Resolution: worksforme
Status: newclosed

Thanks for your providing the details.

I just confirmed. It works for me with valid user/password and smtp.live.com with TLS. That's an InstallationIssue. Please ask it on the MailingList or in the IrcChannel.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.