Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#11128 closed defect (duplicate)

OverflowError: long int too large to convert to int when viewing browser

Reported by: hentis@… Owned by:
Priority: normal Milestone:
Component: version control/browser Version: 0.12
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Ryan J Ollos)

We get this message when trying to view a specific repo in the main "browse source" view. All other repo's seem to be working.

Python Traceback Most recent call last:

    File "/usr/lib/python2.6/site-packages/trac/versioncontrol/templates/dir_entries.html", line 29, in <Expression u'wiki_to_oneliner(chgset_context, change.message, shorten=True)'>
    File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1504, in format_to_oneliner
    File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1480, in generate
    File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1338, in format
    File "/usr/lib/python2.6/re.py", line 151, in sub
    File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1151, in replace
    File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1144, in handle_match
    File "/usr/lib/python2.6/site-packages/trac/ticket/api.py", line 431, in <lambda>
    File "/usr/lib/python2.6/site-packages/trac/ticket/api.py", line 441, in _format_link 

System Information:

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Trac 	0.12
Docutils 	0.6
Genshi 	0.6
mod_python 	3.3.1
Pygments 	1.3.1
pysqlite 	2.4.1
Python 	2.6.5 (release26-maint, Jul 23 2010, 11:26:54) [GCC 4.1.2 (Gentoo 4.1.2 p1.1)]
pytz 	2010h
RPC 	1.1.2-r10614
setuptools 	0.6
SQLite 	3.5.9
Subversion 	1.6.9 (r901367)
jQuery	1.4.2

Enabled Plugins:

BatchModify 	0.8.0-trac0.12 	/usr/lib/python2.6/site-packages/BatchModify-0.8.0_trac0.12-py2.6.egg
changelog 	N/A 	/var/lib/trac/IS/plugins/changelog.pyc
graphviz 	0.7.6dev 	/usr/lib/python2.6/site-packages/graphviz-0.7.6dev-py2.6.egg
TracMasterTickets 	3.0.1 	/usr/lib/python2.6/site-packages/TracMasterTickets-3.0.1-py2.6.egg
TracMath 	0.1 	/usr/lib/python2.6/site-packages/TracMath-0.1-py2.6.egg
TracTags 	0.6 	/usr/lib/python2.6/site-packages/TracTags-0.6-py2.6.egg
TracTocMacro 	11.0.0.3 	/usr/lib/python2.6/site-packages/TracTocMacro-11.0.0.3-py2.6.egg
TracWikiGoodies 	0.11.0.3dev 	/usr/lib/python2.6/site-packages/TracWikiGoodies-0.11.0.3dev-py2.6.egg
TracWikiToPdfPlugin 	2.3.1 	/usr/lib/python2.6/site-packages/TracWikiToPdfPlugin-2.3.1-py2.6.egg
TracWysiwyg 	0.12.0.2-r8148 	/usr/lib/python2.6/site-packages/TracWysiwyg-0.12.0.2_r8148-py2.6.egg
TracXMLRPC 	1.1.2-r10614 	/usr/lib/python2.6/site-packages/TracXMLRPC-1.1.2_r10614-py2.6.egg

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 7 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #10111. Please upgrade to 0.12.3 or later (see TracDownload#PreviousStableRelease).

comment:2 by Ryan J Ollos, 4 years ago

Description: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.