Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

#11083 closed defect (duplicate)

KeyError: 'trac/locale'

Reported by: hao.lulu Owned by:
Priority: normal Milestone:
Component: general Version: 0.12
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /wiki, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.97 Safari/537.22

System Information

Trac 0.12
Babel 0.9.5
Genshi 0.6
Mercurial 2.4
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup mercurial)
pysqlite 2.6.0
Python 2.4.3 (#1, Jan 9 2013, 06:47:03)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-54)]
pytz 2010l
setuptools 0.6c11
SQLite 3.3.6
Subversion 1.6.11 (r934486)
jQuery 1.4.2

Enabled Plugins

pmmm 0.5
TracMercurial 0.12.0.29dev-r10936
TracWysiwyg 0.12.0.4-r11158

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 513, in _dispatch_request
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 200, in dispatch
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 346, in _pre_process_request
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/api.py", line 327, in pre_process_request
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/api.py", line 32, in is_default
  File "build/bdist.linux-x86_64/egg/trac/util/translation.py", line 186, in gettext
  File "build/bdist.linux-x86_64/egg/trac/util/translation.py", line 175, in isactive
  File "build/bdist.linux-x86_64/egg/trac/util/translation.py", line 141, in activate
  File "/usr/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/pkg_resources.py", line 881, in resource_filename
    return get_provider(package_or_requirement).get_resource_filename(
  File "/usr/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/pkg_resources.py", line 1352, in get_resource_filename
    return self._extract_resource(manager, zip_path)
  File "/usr/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/pkg_resources.py", line 1363, in _extract_resource
    zip_stat = self.zipinfo[zip_path]
KeyError: 'trac/locale'

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 8 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #9439.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.