Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

#11065 closed defect (duplicate)

TypeError: unhashable type: 'list'

Reported by: lukasz.matecki@… Owned by:
Priority: normal Milestone:
Component: general Version: 1.1.1dev
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

While on the following page: http://trac.edgewall.org/wiki/TracDev/ReleaseNotes/1.0#MaintenanceRelease

I've clicked the 1.0.1 progress bar (the last one) and got this.

How to Reproduce

While doing a GET operation on /query, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'col': [u'id',
         u'summary',
         u'owner',
         u'type',
         u'priority',
         u'component',
         u'severity',
         u'time',
         u'changetime'],
 'group': u'resolution',
 'max': u'0',
 'milestone': u'1.0.1',
 'order': [u'time', u'id'],
 'status': u'closed'}

User agent: Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.2dev_r11682-py2.6.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.2dev_r11682-py2.6.egg/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.2dev_r11682-py2.6.egg/trac/ticket/query.py", line 938, in process_request
    max)
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.2dev_r11682-py2.6.egg/trac/ticket/query.py", line 78, in __init__
    self.order = synonyms.get(order, order)     # 0.11 compatibility
TypeError: unhashable type: 'list'

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 9 years ago

Milestone: next-dev-1.1.x
Version: 1.1.1dev

Thanks!

The corresponding TicketQuery is:

[[TicketQuery(milestone=1.0.1,group=milestone,format=progress)]]

Funnily, it's only happening for the "closed" ones.

Ah, looking in the "About" page, I see this:

milestone-groups closed.query_args group=resolution,order=time,col=id,col=summary,col=owner,col=type,col=priority,col=component,col=severity,col=time,col=changetime

So here's where the 'time' comes from, in 'order': [u'time', u'id'].

comment:2 by Peter Suter, 9 years ago

Duplicate of #10838?

comment:3 by Christian Boos, 9 years ago

Milestone: next-dev-1.1.x
Resolution: duplicate
Status: newclosed

Ah right! It would be good if you could assign that one to yourself, as you already provided a patch. That way, one can identify the "work in progress" more easily as the ticket ends in the yellow group of its milestone.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.