Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1104 closed defect (invalid)

Can't start Trac on Ubuntu+Python2.3

Reported by: carribeiro Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.8
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I'm having a hard time trying to install Trac on my development PC. Initially I could not make the pre-built trac debian package work for me. It requires a pysqlite 0.5 or greater, and I could not find such a package pre-built for Python 2.3. After some failed attempts, I checked out the current 0.8 trunk code from the repository and installed it (python setup.py install). I've followed the advice on the Wiki page about Trac to configure Apache2. (I've read both TracOnDebian and TracOnDebianFromTrunk).

After all this was done, I could start Trac once. However, when I tried to edit the main page, it blocked. The curious part is that after that, I removed trac, reinstalled it, checked user permissions, and re-initialized the enviroment (with initenv) a few times, but it still gives the same message, and does not show the home page anymore:

Oops...

Trac detected an internal error:

database is locked
Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 537, in cgi_start
    real_cgi_start()
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 532, in real_cgi_start
    dispatch_request(path_info, args, req, env)
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 435, in dispatch_request
    req.session = Session.Session(env, req, newsession)
  File "/usr/lib/python2.3/site-packages/trac/Session.py", line 51, in __init__
    self.get_session(sid)
  File "/usr/lib/python2.3/site-packages/trac/Session.py", line 107, in get_session
    " WHERE sid=%s", self.sid)
  File "/usr/lib/python2.3/site-packages/sqlite/main.py", line 237, in execute
    self.con._begin()
  File "/usr/lib/python2.3/site-packages/sqlite/main.py", line 508, in _begin
    self.db.execute("BEGIN")
OperationalError: database is locked

As I said, the most curious part is that I delete the DB, re-create it, and it still gives the same error. I don't have a clue about it, but I fear that it may be related to my use of Python 2.3.

Attachments (0)

Change History (3)

comment:1 by xamen, 15 years ago

I had this exact same problem on Ubuntu, but upgrading python-sqlite did the trick.

Referring to the last comment on this page:

http://projects.edgewall.com/trac/ticket/468

Note to Ubuntu Warty users :

You'll need to upgrade to python2.3-sqlite v1.0-2 and python-sqlite v 1.0-2. Warty's version is 0.4.3 which is not supported, and doesn't work.

(Sarge has the correct packages in, as does Ubuntu's Hoary)

I downloaded the package from here:

http://archive.ubuntu.com/ubuntu/pool/main/p/python-sqlite/

comment:2 by Christopher Lenz, 15 years ago

Resolution: invalid
Status: newclosed

Looks like this isn't a Trac problem.

comment:3 by carribeiro@…, 15 years ago

Just to let you all know that I made it work, after upgrading Ubuntu from Warty to Hoary. It seemed really strange, because the error message was a little bit misleading. Thanks for all the work!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.