Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#11026 closed defect (duplicate)

ParsingError: File contains parsing errors: /projects/e13021/Soft_Kompjuting/trac/../svn-groups [line 9]: '= rw\n'

Reported by: dusan.prigrevica@… Owned by:
Priority: normal Milestone:
Component: version control Version: 0.11.7
Severity: normal Keywords: svnauthz, needinfo, authzsourcepolicy
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /prefs, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'panel_id': None}

User Agent was: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17

System Information

Trac 0.11.7
Python 2.5.4 (r254:67916, Nov 2 2009, 13:08:35)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools 0.6c11
SQLite 3.6.19
pysqlite 2.5.5
Genshi 0.5.1
mod_wsgi 3.3 (WSGIProcessGroup tracdaemon WSGIApplicationGroup %{GLOBAL})
Pygments 1.1.1
Subversion 1.7.2 (r1207936)
RPC 1.0.6
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.7-py2.5.egg/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.7-py2.5.egg/trac/web/main.py", line 176, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.7-py2.5.egg/trac/web/main.py", line 296, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.7-py2.5.egg/trac/versioncontrol/api.py", line 86, in pre_process_request
    self.get_repository(req.authname).sync()
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.7-py2.5.egg/trac/versioncontrol/api.py", line 157, in get_repository
    repos = self._connector.get_repository(rtype, rdir, authname)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.7-py2.5.egg/trac/versioncontrol/svn_fs.py", line 296, in get_repository
    authname)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.7-py2.5.egg/trac/versioncontrol/svn_authz.py", line 47, in SubversionAuthorizer
    return RealSubversionAuthorizer(repos, authname, module_name, authz_file)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.7-py2.5.egg/trac/versioncontrol/svn_authz.py", line 88, in __init__
    self.conf_authz.read(cfg_file)
  File "/usr/local/lib/python2.5/ConfigParser.py", line 267, in read
    self._read(fp, filename)
  File "/usr/local/lib/python2.5/ConfigParser.py", line 490, in _read
    raise e
ParsingError: File contains parsing errors: /projects/e13021/Soft_Kompjuting/trac/../svn-groups
	[line  9]: '= rw\n'

Attachments (0)

Change History (6)

comment:1 by Christian Boos, 6 years ago

Would you mind attaching that svn-groups file here?

in reply to:  1 comment:2 by anonymous, 6 years ago

Replying to cboos:

Would you mind attaching that svn-groups file here?

A can't access to trac options(Timeline, Roadmap, View Tickets…), always brings me back to this page with error.

comment:3 by Christian Boos, 6 years ago

I meant, show us the content of the following file: /projects/e13021/Soft_Kompjuting/svn-groups.

Seems that line 9 in this file is just = rw, which would be wrong (try * = rw instead?).

comment:4 by Christian Boos, 6 years ago

Component: generalversion control
Keywords: svnauthz needinfo added

comment:5 by Christian Boos, 6 years ago

Resolution: duplicate
Status: newclosed

InstallationIssue and duplicate of #10974.

comment:6 by Ryan J Ollos, 5 years ago

Keywords: authzsourcepolicy added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.