Edgewall Software
Modify

Opened 8 years ago

Closed 7 years ago

#10645 closed defect (worksforme)

Unable to download attachments with + in filenames

Reported by: anatoly techtonik <techtonik@…> Owned by:
Priority: normal Milestone:
Component: attachment Version: 0.12.3
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:

Description

If filename attached to wiki page has special symbols like '+' - it can not be downloaded in Trac 0.12.2 deployed on Debian.

This is not repeatable with current installation as tested on: http://trac.edgewall.org/wiki/PatchWelcomed http://trac.edgewall.org/wiki/TracDev/DatabaseSchema/Attachments

Strangely can not repeat on 0.12 demo too, but it's pretty repeatable on local installation: http://trac.edgewall.org/demo-0.12/wiki/SandBox/ChangesetTest

Attachments (1)

trac-bitten-slave_0.6+final-1_all.deb (49.3 KB ) - added by anatoly techtonik <techtonik@…> 8 years ago.

Download all attachments as: .zip

Change History (6)

by anatoly techtonik <techtonik@…>, 8 years ago

comment:1 by Christian Boos, 8 years ago

… so what makes you think it's a bug in Trac and not an InstallationIssue?

comment:2 by anatoly techtonik <techtonik@…>, 8 years ago

well, because files without + in their names are uploaded and downloaded without any problems.

comment:3 by Remy Blank, 7 years ago

Keywords: needinfo added

I can't reproduce this here either, with 0.12-stable. It does sound like a double-encoding issue. Are you using some kind of proxy, or even nginx, by any chance?

comment:4 by anatoly techtonik <techtonik@…>, 7 years ago

nginx, yes.

comment:5 by Christian Boos, 7 years ago

Milestone: 0.12.4
Resolution: worksforme
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.