Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

#1058 closed defect (worksforme)

Incorrect encoding of file names in subversion repository

Reported by: eaglewang@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: none
Severity: critical Keywords: browser
Cc: eaglewang@… Branch:
Release Notes:
API Changes:

Description

I am a Chinese.
I have a subversion repository.There are directory names and file names in Chinese. Now,the question is :

  • if a directory name in Chinese:
    --------------------------------
    No such file or directory
    "/tags/΄µµ»񏟯": no such file or directory in revision 247 
    
    TracGuide — The Trac User and Administration Guide 
    -----------------------------
    
  • if a file name in Chinese:
    -----------------------------
    Oops...
    Trac detected an internal error: 
    null argument to internal routineIf you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team. 
    
    Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below. 
    
    TracGuide — The Trac User and Administration Guide 
    
    Python traceback
    Traceback (most recent call last):
      File "C:\ContIntg\Python\Lib\site-packages\trac\core.py", line 525, in cgi_start
        real_cgi_start()
      File "C:\ContIntg\Python\Lib\site-packages\trac\core.py", line 520, in real_cgi_start
        dispatch_request(path_info, args, req, env)
      File "C:\ContIntg\Python\Lib\site-packages\trac\core.py", line 435, in dispatch_request
        module.run()
      File "C:\ContIntg\Python\Lib\site-packages\trac\Module.py", line 44, in run
        self.render()
      File "C:\ContIntg\Python\Lib\site-packages\trac\File.py", line 282, in render
        oh = svn.fs.node_history(root, self.path, self.pool)
    SystemError: null argument to internal routine
    -----------------------------------
    
  • if the content of a file in Chinese:
    ----------------------------------
    ==×¢Òâ==:
    1¡¢Ã¿ŽÎÌ᜻ǰÇëÎñ±ØÏÈupdateÒ»ÏÂ.
    2¡¢žÃÅäÖÿâÄ¿Ç°µÄ·ÃÎÊ·Ÿ¶Îª£º
    -----------------------------------
    

ok,that's all.oh,my poor english.

Attachments (0)

Change History (11)

comment:1 by anonymous, 15 years ago

Have you set the default_charset option in the [trac] section of trac.ini?

comment:2 by anonymous, 15 years ago

I have set the default_charset option to cp936.
if the content of a file in Chinese, it's ok.

but if a directory name in Chinese or a file name in Chinese,the question is not ok.

thanks!

comment:3 by eaglewang@…, 15 years ago

and there are the same questions when i use the "attach files" function .

comment:4 by anonymous, 15 years ago

Cc: eaglewang@… added

comment:5 by eaglewang@…, 15 years ago

anyone give an answer,please!

comment:6 by Christopher Lenz, 15 years ago

Summary: Charset ???Incorrect encoding of file names in subversion repository

Trying to give this ticket a better summary.

The file contents are decoded/encoded properly, but the file name isn't. If I understand correctly, that is.

comment:7 by yxy.top, 14 years ago

is there someone doing it correct? how

comment:8 by anonymous, 14 years ago

I have exactly the same problem and getting the same error messages when a file or directory contains a german umlaut.

The displayed URL contains the correct UTF-8 hexadecimal codings.

Our actual installation is W2003 Server / trac 0.8 / Python 2.3.4 / Apache 2.0.52 / Subversion 1.2.1

comment:9 by anonymous, 14 years ago

Priority: highnormal

comment:10 by Christian Boos, 14 years ago

Component: browsergeneral

Any chance someone could create a small repository dump which reproduces the issue and attach it here?

Personally, I've never had any problems using filenames containing accented characters, neither in Subversion nor for attachments.

comment:11 by Christian Boos, 14 years ago

Resolution: worksforme
Status: newclosed

I believe that directory and filenames in the TracBrowser should be working as expected with unicode characters, after r3092. The same for attachments, since r3103.

Please try out the latest from trunk and let us know if everything works as expected.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.