Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#10524 closed defect (worksforme)

file:/// links have stopped working in IE (and other browsers)

Reported by: sokaku@… Owned by:
Priority: high Milestone:
Component: general Version: 0.12-stable
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Same issue as raised in #10521 but no resolution. With trac 0.11 file/folder links worked fine. With 0.12 they no longer work.

Browser IE 8.0 Also tried IE 9.0 & Chrome. Same behavior. The links were verfied as working in trac 0.11 with IE 8, 9, and Chrome.

Steps to repro: Created links to network folder and a text file within the network folder. Submit the page, both links appear, show the paths in the status bar for IE, but clicking on the link does nothing.

Using IE I saved the page as Complete HTML, and as a Microsoft Web Archive. (Both attached) When the saved HTML page is opened, the link works. With the Web Archive is opened the link does not work.

Note: In attachments the server name has been changed. To reproduce using the attached archives, replace the server name/path inside the HTML file and the web archive with an applicable network location.

Attachments (2)

BugRepro 10524 (HTML).zip (89.6 KB ) - added by sokaku@… 10 years ago.
HTML export which does not exhibit the problem
BugRepro 10524 (WebArch).zip (92.7 KB ) - added by sokaku@… 10 years ago.
Web Archive file (IE) that does exhibit the link problem.

Download all attachments as: .zip

Change History (3)

by sokaku@…, 10 years ago

Attachment: BugRepro 10524 (HTML).zip added

HTML export which does not exhibit the problem

by sokaku@…, 10 years ago

Web Archive file (IE) that does exhibit the link problem.

comment:1 by Christian Boos, 10 years ago

Resolution: worksforme
Status: newclosed

Reproduced with the (WebArch) above, but…

In both cases, the HTML for the link is:

<DIV id=wikipage>
<P><A class=ext-link href="file://server/Software/Development"><SPAN 
class=icon>&nbsp;</SPAN>Test Folder</A><BR><A class=ext-link 
href="file://server/Software/Development/Test.txt"><SPAN 
class=icon>&nbsp;</SPAN>Test File</A> </P></DIV>

So the difference must be elsewhere…

If I save the Web Archive back to an HTML file (complete), then the "problem" is gone, but some .css files are missing as well, so this might explain the difference.

Well, if in the generated .html I fix the references to point to the same .css from the 0.11 version, then the problem is still gone.

Replacing those .css files one by one with those from 0.12: also no problem…

So in order to be able to reproduce your problem, we would need a self-contained (HTML).zip also in the second case, as it really seems there's an issue with this WebArch format.

Besides, testing locally with either latest 0.12-stable or 0.13dev shows no problem, it works (only with IE, of course).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.