Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

#10469 closed defect (duplicate)

OperationalError: database is locked

Reported by: khamdy Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /query, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'col': [u'id',
         u'summary',
         u'resource',
         u'status',
         u'owner',
         u'type',
         u'priority'],
 'group': u'severity',
 'or': u'',
 'order': u'priority',
 'owner': u'$USER',
 'report': u'7',
 'resource': u'khamdy',
 'status': [u'accepted',
            u'assigned',
            u'new',
            u'reopened',
            u'Dev_Complete',
            u'QA_Failed',
            u'accepted',
            u'assigned',
            u'new',
            u'reopened']}

User agent: #USER_AGENT#

System Information

Trac 0.12.2
Genshi 0.6
mod_python 3.2.8
pysqlite 2.3.3
Python 2.4.3 (#1, Jun 11 2009, 14:09:37)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-44)]
setuptools 0.6c9
SQLite 3.3.6
Subversion 1.4.2 (r22196)
jQuery #JQUERY#

Enabled Plugins

TracAccess 0.1
TracAccountManager 0.3dev-r9785
TracWysiwyg 0.2-r7817

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/web/main.py", line 260, in dispatch
    req.session.save()
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/web/session.py", line 105, in save
    @self.env.with_transaction()
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/db/api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/web/session.py", line 137, in save_session
    cursor.execute("""
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/db/sqlite_backend.py", line 78, in execute
    result = PyFormatCursor.execute(self, *args)
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/db/sqlite_backend.py", line 56, in execute
    args or [])
  File "/usr/lib/python2.4/site-packages/Trac-0.12.2-py2.4.egg/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked

Attachments (0)

Change History (1)

comment:1 by Remy Blank, 8 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #10468.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.