Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#1037 closed enhancement (duplicate)

Only view parts of tree in Browse Source

Reported by: Manuzhai Owned by: Jonas Borgström
Priority: low Milestone:
Component: general Version: 0.8
Severity: normal Keywords:
Cc: mail@… Branch:
Release Notes:
API Changes:

Description

For repositories which contain several projects, an administrator may not want users to be able to browse all of the source tree. The attached patch to the Browser module adds an optional flag in trac.ini, repository_offset, which prevents all users from viewing anything in another part of the Subversion tree. I'm afraid this is only the start, other patches will need to be made to the Log, File, Timeline and Changeset modules.

Attachments (1)

NewBrowser.diff (568 bytes ) - added by mail@… 15 years ago.
Diff to Browser.py

Download all attachments as: .zip

Change History (3)

by mail@…, 15 years ago

Attachment: NewBrowser.diff added

Diff to Browser.py

comment:1 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #586.

comment:2 by Matthew Good, 14 years ago

Milestone: 0.9

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.