Edgewall Software
Modify

Opened 18 years ago

Closed 18 years ago

Last modified 14 years ago

#1028 closed enhancement (duplicate)

combo box with user names and mail address

Reported by: achim@… Owned by: Christopher Lenz
Priority: high Milestone:
Component: ticket system Version: 0.8
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

it would be nice to have a combo box for the assigned to input box in the new ticket dialog with a list of known users. this list should also have the mail adresses (simple address or mailing lists) of this users to send them a mail if a new ticket arrived.

Attachments (1)

patch-emailnotify-r1106.diff (13.5 KB ) - added by pkou <pkou at ua.fm> 18 years ago.
Patch for the changes

Download all attachments as: .zip

Change History (9)

comment:1 by pkou <pkou at ua.fm>, 18 years ago

Attached patch provides a solution for this problem. (I did not create a new ticket because the description of this ticket is almost identical to what the patch does.)

The patch provides the following features:

  • Global settings for non-anonymous users;
  • Assigning a ticket to user via combo box, which lists all project users;
  • Displaying a user name in the combo box for ticket assignments;
  • Sending a notification to ticket owners only;
  • Entering user login in ticket cc field for receiving email notifications.

The idea of the patch is the following:

  • Every logged user has global session settings, which include fullname, email, wiki editing settings, parameters of diff display, and so on. The global settings are updated when user changes session settings. When user creates a new session, it uses global settings by default (which can be overridden of course).
  • When logged user has entered his/her email, it is saved in global settings and used for email notifications. User login name can be used in ticket owner and cc fields and it is translated to email address when it is necessary;
  • By specifying always_notify_owner=true in section [notification] of trac.ini, it is possible to receive a notification when a ticket is assigned to user;
  • By specifying restrict_owner=true in section [ticket] of trac.ini, it is possible to limit ticket owners to logged users only. Users are assigned using combo box. If a user has entered his/her full name via Settings page, then the combo box displays both user login and full name.

Thus, in order to use combo boxes for ticket assignment and email notifications for ticket owner, it is necessary to make the following changes in a project:

  • Every user that can work on tickets should have a login in the project;
  • As a first step, every user should go to Settings page and enter his/her fullname and email.

by pkou <pkou at ua.fm>, 18 years ago

Patch for the changes

comment:2 by Josh Burley <jburley@…>, 18 years ago

This is exactly what I'm looking for.

I've applied the patch and added the smtp_replyto to the .ini, but it doesn't seem to be sending the notifications as expected (sessions table is filled with all of the appropriate email addresses).

I'll continue trying to debug this, now.

comment:3 by pkou <pkou at ua.fm>, 18 years ago

Please check your environment. We have applied the patch to our projects and it works well.

If a user in your project experiences problems, then try to recreate his/her session: Login, go to URL http-to-your-project/settings?newsession=1, reenter user fullname/email, press Save Changes.

Another way is to clean session table:

sqlite project-path/db/trac.db "DELETE FROM session;"

This means that every user in your project will need to reenter name/email.

comment:4 by Christopher Lenz, 18 years ago

Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

Great patch, pkou. Very elegant.

comment:5 by Christopher Lenz, 18 years ago

Resolution: duplicate
Status: assignedclosed

This is actually a duplicate of #222.

comment:6 by Christopher Lenz, 18 years ago

Pkou, I've had a look at your patch and added a slightly reworked version to #222. Please have a look.

comment:7 by Matthew Good, 17 years ago

Milestone: 0.9

comment:8 by anonymous, 14 years ago

Type: defectenhancement

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.