Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1025 closed enhancement (duplicate)

Multiple projects: add option for Browse Source to link to top of project in repository

Reported by: matthew.harrison@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.8
Severity: normal Keywords: project browse source
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

Where multiple projects are stored in the svn repository:

/projecta
/projectb
/projectc

it would be nice if Browse Source could link directly to the top of each within the repository, rather than always linking to the top level.

Perhaps I'm missing something, but I couldn't find how to configure it to do this.

Attachments (0)

Change History (4)

comment:1 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #130.

comment:2 by matthew.harrison@…, 15 years ago

I'm not so concerned with multiple repositories, but multiple source trees within the one repository. We are already using multiple trac databases, but sharing a single svn repository (as we don't want the overhead of one repository per project). This works fine, except for the minor inconvenience I'm describing below.

My suggestion is merely that instead of the Browse source linking from

http://trac/projects/ProjectA/

to

http://trac/projects/ProjectA/Browser

and then always having to click on ProjectA to get to

http://trac/projects/ProjectA/Browser/ProjectA

to get to where I wanted to be, that it be possible to link there directly.

Cheers.

comment:3 by Christopher Lenz, 15 years ago

Description: modified (diff)

If I understand you correctly this is the same as #586, right?

comment:4 by matthew.harrison@…, 15 years ago

That sounds more like it, yes.

(We are actually evaluating trac on a pilot project (consisting of 5 subprojects) and I'm thinking ahead to how we might roll it out to the rest of R&D.)

We may actually go the multi-repository route after all, but not divide each into subprojects. But that's what pilot projects are for, to discover the right granularity for your purposes.

many thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.