Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

#10177 closed defect (duplicate)

DataError: (1264, "Out of range value for column 'due' at row 1")

Reported by: chowell@… Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a POST operation on /admin/ticket/milestones, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'63b5054afc014437761959b3',
 'add': u'Add',
 'cat_id': u'ticket',
 'duedate': u'06/01/2011',
 'name': u'Test',
 'panel_id': u'milestones',
 'path_info': None}

User agent: Opera/9.80 (Windows NT 6.1; U; en) Presto/2.6.30 Version/10.63

System Information

Trac 0.12.3dev-r10683
Babel 0.9.5
FullBlog 0.1.1-r9430
Genshi 0.6
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
MySQL server: "5.5.11", client: "5.1.50", thread-safe: 1
MySQLdb 1.2.3
Python 2.7.1 (r271:86832, Nov 27 2010, 18:30:46) [MSC v.1500 32 bit (Intel)]
RPC 1.1.2-r9970
setuptools 0.6c11
jQuery 1.4.4

Enabled Plugins

duplicateticketsearch 1.0.1
estimatorplugin 0.2.5
timingandestimationplugin 1.1.3b
tracdiscussion 0.8-r9877
tracexcelviewer 0.1
tracfullblogplugin 0.1.1-r9430
tracsectioneditplugin 0.1.1
tractags 0.6
tracvote 0.1.3
tracwysiwyg 0.12.0.3-r9676
tracxmlrpc 1.1.2-r9970

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 517, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 238, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\trac\admin\web_ui.py", line 116, in process_request
    path_info)
  File "build\bdist.win32\egg\trac\ticket\admin.py", line 53, in render_admin_panel
    return self._render_admin_panel(req, cat, page, version)
  File "build\bdist.win32\egg\trac\ticket\admin.py", line 298, in _render_admin_panel
    mil.insert()
  File "build\bdist.win32\egg\trac\ticket\model.py", line 985, in insert
    @self.env.with_transaction(db)
  File "build\bdist.win32\egg\trac\db\api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "build\bdist.win32\egg\trac\ticket\model.py", line 993, in do_insert
    to_utimestamp(self.completed), self.description))
  File "build\bdist.win32\egg\trac\db\util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "C:\Python27\lib\site-packages\MySQLdb\cursors.py", line 174, in execute
    self.errorhandler(self, exc, value)
  File "C:\Python27\lib\site-packages\MySQLdb\connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
DataError: (1264, "Out of range value for column 'due' at row 1")

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by Remy Blank

Can you please check that the due column in the milestone table of your database has type bigint?

comment:2 Changed 7 years ago by Christian Boos

Resolution: duplicate
Status: newclosed

Probably a duplicate of #9403.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.