Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#1007 closed defect (fixed)

"Diff" feature is broken for Wiki pages

Reported by: eblotml@… Owned by: Christopher Lenz
Priority: high Milestone: 0.8.1
Component: wiki system Version: 0.8
Severity: major Keywords: wiki diff
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

The "inline"/"side-by-side" selector does not show the right Wiki page differences.

When the diff mode is changed, the difference is processed onto the default Wiki page (WikiStart), not onto the current Wiki page

The bug shows itself on the current TRAC web site.

Attachments (0)

Change History (4)

comment:1 by Christopher Lenz, 15 years ago

Looks like a duplicate of #903. Problem is that #903 is closed as fixed (in [1041]), and switching diff style works for me under both CGI and mod_python. In particular I am not seeing this problem on http://projects.edgewall.com/trac/.

Please provide more details.

comment:2 by anonymous, 15 years ago

How to reproduce the issue:

Go to http://projects.edgewall.com/trac/wiki/TracInstall Select "Page History" Select first line, Version: 74 (diff), click on 'diff' link

→ works fine, displays

http://projects.edgewall.com/trac/wiki/TracInstall?version=74&diff=yes

Change the type of view (side-by-side to inline, or the opposite, inline to side-by-side)

→ breaks: Trac displays the following URL

http://projects.edgewall.com/trac/wiki/WikiStart?version=74&diff=yes

With a Firefox 1.0 browser / WinXP SP1

comment:3 by Christopher Lenz, 15 years ago

Description: modified (diff)
Owner: changed from Jonas Borgström to Christopher Lenz
Priority: normalhigh
Severity: normalmajor
Status: newassigned

Okay, I see the problem now. Thanks.

comment:4 by Christopher Lenz, 15 years ago

Resolution: fixed
Status: assignedclosed

Fixed in [1119], ported to 0.8 in [1120].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.