Edgewall Software

Changes between Version 107 and Version 108 of TracUpgrade


Ignore:
Timestamp:
Jan 15, 2015, 4:50:32 PM (7 years ago)
Author:
Jun Omae
Comment:

Use intertrac for PySqlite

Legend:

Unmodified
Added
Removed
Modified
  • TracUpgrade

    v107 v108  
    100100SQLite v2.x is no longer supported. If you still use a Trac database of this format, you'll need to convert it to SQLite v3.x first. See [trac:PySqlite#UpgradingSQLitefrom2.xto3.x] for details.
    101101
    102 ===== PySqlite 2 required =====
    103 PySqlite 1.1.x is no longer supported. Please install 2.5.5 or later if possible, see [#Tracdatabaseupgrade Trac database upgrade] below.
     102===== [trac:PySqlite] 2 required =====
     103[trac:PySqlite] 1.1.x is no longer supported. Please install 2.5.5 or later if possible, see [#Tracdatabaseupgrade Trac database upgrade] below.
    104104
    105105===== Multiple Repository Support =====
     
    197197=== Trac database upgrade ===
    198198
    199 A known issue in some versions of PySqlite (2.5.2-2.5.4) prevents the trac-admin upgrade script from successfully upgrading the database format. It is advised to use either a newer or older version of the sqlite python bindings to avoid this error. For more details see ticket [trac:#9434].
     199A known issue in some versions of [trac:PySqlite] (2.5.2-2.5.4) prevents the trac-admin upgrade script from successfully upgrading the database format. It is advised to use either a newer or older version of the sqlite python bindings to avoid this error. For more details see ticket [trac:#9434].
    200200
    201201=== Parent dir ===