Edgewall Software

Changes between Version 444 and Version 445 of TracInstall


Ignore:
Timestamp:
Jun 3, 2020, 12:56:36 AM (4 months ago)
Author:
Ryan J Ollos
Comment:

Genshi template support dropped in 1.5.1.

Legend:

Unmodified
Added
Removed
Modified
  • TracInstall

    v444 v445  
    33[[TranslatedPages]]
    44
    5 Trac is written in the Python programming language and needs a database, [https://sqlite.org/ SQLite], [https://www.postgresql.org/ PostgreSQL], or [https://mysql.com/ MySQL]. For HTML rendering, Trac uses the [http://jinja.pocoo.org Jinja2] templating system, though Genshi templates will still be supported until at least Trac 1.5.1.
     5Trac is written in the Python programming language and needs a database, [https://sqlite.org/ SQLite], [https://www.postgresql.org/ PostgreSQL], or [https://mysql.com/ MySQL]. For HTML rendering, Trac uses the [http://jinja.pocoo.org Jinja2] templating system, though Genshi templates are supported until Trac 1.5.1.
    66
    77Trac can also be localized, and there is probably a translation available in your language. If you want to use the Trac interface in other languages, then make sure you have installed the optional package [#OtherPythonPackages Babel]. Pay attention to the extra steps for localization support in the [#InstallingTrac Installing Trac] section below. Lacking Babel, you will only get the default English version.