Edgewall Software

Changes between Version 213 and Version 214 of TracDownload


Ignore:
Timestamp:
Aug 29, 2019, 4:13:00 AM (3 weeks ago)
Author:
Ryan J Ollos
Comment:

Fix some links.

Legend:

Unmodified
Added
Removed
Modified
  • TracDownload

    v213 v214  
    88Please read TracUpgrade if you're upgrading from a previous release.
    99
    10 The latest releases of Trac are also available on [https://pypi.python.org/pypi/Trac PyPI].
     10The latest releases are also available on [pypi:Trac PyPI].
    1111
    1212== Latest Stable Release for the 1.4.x line #Trac14StableRelease
     
    1414Here's the latest and greatest version of Trac.
    1515
    16 See the [[TracDev/ReleaseNotes/1.4#MaintenanceRelease|release notes]] for details.
     16See the [[TracDev/ReleaseNotes/1.4#MaintenanceReleases|release notes]] for details.
    1717
    1818[[TracDownloads(Trac-latest)]]
     
    2323
    2424=== About the prerequisites for Trac 1.4.x
    25  - Python 2.7 (+[https://pypi.python.org/pypi/setuptools#windows-simplified setuptools])
     25 - Python 2.7 (+[pypi:setuptools])
    2626 - Jinja2: [pypi:jinja2 >= 2.9.3]
    27  - Genshi: [pypi:genshi >= 0.7] (or [https://genshi.edgewall.org/wiki/Download#LatestRelease:0.7 0.7 win32 installer] available) optional, but needed by many plugins.
    28  - Babel: [https://pypi.python.org/pypi/Babel/1.3 1.3] (or [https://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6], win32 installer available) needed for localizing Trac, otherwise optional. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     27 - '''*''' Genshi: [pypi:genshi >= 0.7] (or [https://genshi.edgewall.org/wiki/Download#LatestRelease:0.7 0.7 win32 installer] available), but needed by many plugins.
     28 - '''*''' Babel: [pypi:Babel >= 0.9.5] (or [https://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6] win32 installer available) needed for localizing Trac. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     29'''*''' optional
    2930
    30 For Windows x64, there are no installers for Genshi and Babel so install them by [TracInstall#Usingpip using pip].
     31For Windows x64, there are no installers for Genshi and Babel so install them [TracInstall#Usingpip using pip].
    3132}}}
    3233
     
    3536=== Latest Stable Release for the 1.2.x line #Trac12StableRelease
    3637
    37 Here's the latest version of our previous stable release line (1.2.x) of Trac.
     38Here's the latest version of the 1.2.x release line.
    3839See the [[TracDev/ReleaseNotes/1.2|release notes]] for details. This release line is still supported although it is now recommended to upgrade to the [#LatestStableRelease 1.4.x release line].
    3940
     
    4546
    4647=== About the prerequisites for Trac 1.2.x
    47  - Python 2.6 or 2.7 (+[https://pypi.python.org/pypi/setuptools#windows-simplified setuptools])
    48  - Genshi: [https://genshi.edgewall.org/wiki/Download#LatestRelease:0.7 0.7] (or [https://genshi.edgewall.org/wiki/Download#a0.6.1-2013-01-27 0.6.1]) (win32 installer available)
    49  - Babel: [https://pypi.python.org/pypi/Babel/1.3 1.3] (or [https://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6], win32 installer available) needed for localizing Trac, otherwise optional. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     48 - Python 2.6 or 2.7 (+[pypi:setuptools])
     49 - Genshi: [pypi:genshi >= 0.6] (or [https://genshi.edgewall.org/wiki/Download#a0.6.1-2013-01-27 0.6.1]) (win32 installer available)
     50 - '''*''' Babel: [pypi:babel >= 0.9.5] (or [https://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6], win32 installer available) needed for localizing Trac. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     51'''*''' optional
    5052
    51 For Windows x64, there are no installers for Genshi and Babel so install them by [wiki:1.2/TracInstall#Usingeasy_install using easy_install].
     53For Windows x64, there are no installers for Genshi and Babel so install them by [wiki:1.2/TracInstall#Usingeasy_install using easy_install] (or pip).
    5254}}}
    5355
    5456=== Latest Stable Release for the 1.0.x line #Trac10StableRelease
    5557
    56 Here's the latest version of our previous stable release line (1.0.x) of Trac.
     58Here's the latest version of the 1.0.x release line.
    5759See the [[TracDev/ReleaseNotes/1.0|release notes]] for details. This release line is still supported although it is now recommended to upgrade to the [#LatestStableRelease 1.4.x release line].
    5860
     
    6466
    6567=== About the prerequisites for Trac 1.0.x
    66  - Python 2.5, 2.6 or 2.7 (+[https://pypi.python.org/pypi/setuptools#windows-simplified setuptools])
    67  - Genshi: [https://genshi.edgewall.org/wiki/Download#LatestRelease:0.7 0.7] (or [https://genshi.edgewall.org/wiki/Download#a0.6.1-2013-01-27 0.6.1]) (win32 installer available)
    68  - Babel: [https://pypi.python.org/pypi/Babel/1.3 1.3] (or [https://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6], win32 installer available) needed for localizing Trac, otherwise optional. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     68 - Python 2.5, 2.6 or 2.7 (+[pypi:setuptools])
     69 - Genshi: [pypi:genshi >= 0.6] (or [https://genshi.edgewall.org/wiki/Download#a0.6.1-2013-01-27 0.6.1]) (win32 installer available)
     70 - '''*''' Babel: [pypi:babel >= 0.9.5] (or [https://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6], win32 installer available) needed for localizing Trac. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     71'''*''' optional
    6972
    70 For Windows x64, there are no installers for Genshi and Babel so install them by [wiki:1.0/TracInstall#Usingeasy_install using easy_install].
     73For Windows x64, there are no installers for Genshi and Babel so install them by [wiki:1.0/TracInstall#Usingeasy_install using easy_install] (or pip).
    7174}}}
    7275
    7376=== Older Releases
    7477
    75 Older releases and auxiliary files are archived on the FTP server:
     78Older releases are archived on the FTP server:
    7679
    7780 * https://download.edgewall.org/trac/
     
    8588
    8689The //really// latest and greatest version of Trac. However this is a development release, so a few caveats are in order:
    87  - don't expect the level of API or feature stability you'll get from either 1.0.x, 1.2.x or 1.4.x
     90 - the Genshi template engine has been removed,
     91   so many plugins won't work.
     92 - don't expect the level of API or feature stability you'll get 1.0.x, 1.2.x or 1.4.x
    8893 - don't use in production unless you're at ease with backup, upgrade and manual downgrade procedures
    8994 - don't ship this one in your favorite distribution if you're a Trac package maintainer
    90  - the Genshi template engine has been removed
    9195
    9296[[TracDownloads(Trac-latest-dev, #fda)]]
     
    101105
    102106=== About the prerequisites for Trac 1.5.x
    103  - Python 2.7 exclusively (+[https://pypi.python.org/pypi/setuptools#windows-simplified setuptools])
    104  - [https://pypi.python.org/pypi/Jinja Jinja] -- will be installed automatically when installing Trac
    105  - [https://pypi.python.org/pypi/Babel Babel] -- needed for localizing Trac, otherwise optional. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
    106    \\ Versions that should work:  [https://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6], 1.3, 2.6.0 \\
     107 - Python 2.7 (+[pypi:setuptools])
     108 - [pypi:Jinja Jinja] -- will be installed automatically when installing Trac
     109 - '''*''' Babel [pypi:Babel >= 0.9.5] (or [https://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6], win32 installer available) -- needed for localizing Trac. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     110'''*''' optional
    107111
    108112For Windows x64, there are no installers for Babel so install them by [TracInstall#Usingpip using pip].
     
    134138svn co https://svn.edgewall.org/repos/trac/trunk trac
    135139}}}
    136 (https: also works)
    137140
    138141Be sure to read [[1.5/TracUpgrade]] and [[1.5/TracInstall]] for the specific installation instructions for this version.
    139142
    140143=== Trac ''1.4-stable'' #Tracstable
    141 The latest revision for the upcoming [https://svn.edgewall.org/repos/trac/branches/1.4-stable#egg=Trac-1.4-dev next maintenance release] of Trac ([milestone:next-stable-1.2.x]) can be checked out with the following command:
     144The latest revision for the upcoming [https://svn.edgewall.org/repos/trac/branches/1.4-stable#egg=Trac-1.4-dev next maintenance release] of Trac ([milestone:next-stable-1.4.x]) can be checked out with the following command:
    142145{{{#!sh
    143146svn co https://svn.edgewall.org/repos/trac/branches/1.4-stable trac
     
    152155Alternatively, you can directly "pip install" the latest stable version from the repository:
    153156{{{#!sh
    154 pip install https://svn.edgewall.org/repos/trac/branches/1.4-stable
     157pip install svn+https://svn.edgewall.org/repos/trac/branches/1.4-stable
    155158}}}
    156159
     
    172175We recommend that you choose some well visible place (e.g. `/opt/trac-1.2dev`), and override the PYTHONPATH environment variable (or !PythonPath path directive for `mod_python`) by ''prepending'' the `/opt/trac-1.2dev/lib/python2.7/site-packages` path (replace 2.7 by the Python version that you actually use). That way, you minimize the risk of interferences with the packaged Trac version you probably already have.
    173176{{{#!sh
    174 cd 1.2-stable
    175 python setup.py install --prefix=/opt/trac-1.2dev
     177$ cd 1.2-stable
     178$ python setup.py install --prefix=/opt/trac-1.2dev
    176179}}}
    177180then:
    178181{{{#!sh
    179 export PYTHONPATH=/opt/trac-1.2dev/lib/python2.7/site-packages:$PYTHONPATH
     182$ export PYTHONPATH=/opt/trac-1.2dev/lib/python2.7/site-packages:$PYTHONPATH
    180183}}}
    181184or, in your httpd.conf: