Edgewall Software

Changes between Version 159 and Version 160 of TracDownload


Ignore:
Timestamp:
Oct 25, 2014, 8:48:20 PM (5 years ago)
Author:
Christian Boos
Comment:

Add a few notes about the main prerequisites for each version

Legend:

Unmodified
Added
Removed
Modified
  • TracDownload

    v159 v160  
    3434Again, be sure to read [[TracInstall]] and [[TracUpgrade]] before installing or upgrading, then proceed by reading the rest of the [[TracGuide]]. If you have any trouble, check the TracSupport page which explains how to get help.
    3535
     36{{{#!div style="border: 1px dotted #aaa; background: #ffe; width: 26em; margin: auto; padding: 0 2em; font-size: 90%"
     37
     38=== About the prerequisites for Trac 1.0.x
     39 - Python 2.5, 2.6 or 2.7
     40 - Genshi: [http://genshi.edgewall.org/wiki/Download#LatestRelease:0.7 0.7] (or [http://genshi.edgewall.org/wiki/Download#a0.6.1-2013-01-27 0.6.1]) (win32 installer available)
     41 - Babel: [https://pypi.python.org/pypi/Babel/1.3 1.3] (or [http://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6]) needed for localizing Trac, otherwise optional. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     42
     43For Windows x64, there are no installers for Genshi and Babel so install them by [TracInstall#Usingeasy_install using easy_install].
     44}}}
    3645
    3746{{{#!comment
     
    117126}}}
    118127
     128Be sure to read the [[0.12/TracUpgrade]] page and the [[0.12/TracInstall]] page.
     129
     130{{{#!div style="border: 1px dotted #aaa; background: #f6f6f6; width: 22em; margin: auto; padding: 0 2em; font-size: 90%"
     131
     132=== About the prerequisites for Trac 0.12.x
     133 - Python 2.4, 2.5, 2.6 or 2.7
     134 - Genshi: [http://genshi.edgewall.org/wiki/Download#a0.6.1-2013-01-27 0.6.1] (win32 installer available)
     135 - Babel: [https://pypi.python.org/pypi/Babel/1.3 1.3] (or [http://babel.edgewall.org/wiki/Download#LatestRelease:0.9.6-2011-03-17 0.9.6]) needed for localizing Trac, otherwise optional. Note that it needs to be installed **before** Trac when installing the latter from source (.gz or .zip).
     136
     137For Windows x64, there are no installers for Genshi and Babel so install them by [TracInstall#Usingeasy_install using easy_install]. \\ \\ (use `easy_install 'genshi<=0.6.1'` to avoid installing 0.7 which is not compatible with Trac 0.12.x)
     138}}}
     139
    119140=== Latest Stable Release for the 0.11.x line - Trac 0.11.7 #LegacyStableRelease
    120141
    121 ''Note that the 0.11.x release line is no longer maintained - use 1.0.x for new installations and upgrade to 1.0.x whenever possible (or at least to 0.12.x if you still need to work with Python 2.4)''
     142''Note that the 0.11.x release line is no longer maintained, and really, you shouldn't be using it anymore - use 1.0.x for new installations and upgrade to 1.0.x whenever possible (or at least to 0.12.x if you still need to work with Python 2.4)''
    122143
    123144{{{#!div style="border: 1px dotted #aaa; background: #fafafa; width: 25em; margin: auto; padding: .5em 3em;"
     
    172193(https: also works)
    173194
    174 Be sure to read TracUpgrade and TracInstall for the specific installation instructions for this version.
     195Be sure to read [[1.1/TracUpgrade]] and [[1.1/TracInstall]] for the specific installation instructions for this version.
    175196
    176197