Edgewall Software

Changes between Version 30 and Version 31 of TracDev/ApiChanges/1.3


Ignore:
Timestamp:
Feb 13, 2018, 3:07:52 PM (6 months ago)
Author:
Ryan J Ollos
Comment:

Add Debian 9.3

Legend:

Unmodified
Added
Removed
Modified
  • TracDev/ApiChanges/1.3

    v30 v31  
    7676The supported dependencies were determined by aiming to be compatible with the versions provided by the package managers on the following distros.
    7777
    78 || **Package** || **Ubuntu 16.04** || Ubuntu 14.04 || **Debian 8.8** || Debian 7.8 || **CentOS 7.4** || **openSUSE 42.1** ||
    79 || Python      || 2.7.12           || 2.7.5          || 2.7.9        || 2.7.3      || 2.7.5          || 2.7.9             ||
    80 || Python3     || 3.5.2            || 3.4.0          || 3.4.2        || 3.2.3      || n/a            || 3.4.1             ||
    81 || Babel       || 1.3              || 1.3            || 1.3          || 0.9.6      || 0.9.6          || 1.3               ||
    82 || Genshi      || 0.7              || 0.7            || 0.7          || 0.6        || n/a            || 0.7               ||
    83 || SQLite3     || 3.11.0           || 3.8.2          || 3.8.7        || 3.7.13     || 3.7.17         || 3.8.10.2          ||
    84 || PostgreSQL  || 9.5.3            || 9.3.6          || 9.4.12       || 9.1.15     || 9.2.23         || 9.4, 9.3.11, 9.4.6 ||
    85 || MySQL       || 5.7.13           || 5.5.41, 5.6.19 || 5.5.55       || 5.5.41     || n/a            || 5.6.30            ||
    86 || MariaDB     || 10.0.25          || 5.5.41         || 10.0.30      || n/a        || 5.5.56         || 10.0.22           ||
    87 || psycopg2    || 2.6.1            || 2.4.5          || 2.5.4        || 2.4.5      || 2.5.1          || 2.6               ||
    88 || PyMySQL     || 0.7.2            ||                || n/a          ||            || n/a            ||                   ||
    89 || SetupTools  || 20.7             || 3.3.1          || 5.5.1        || 0.6.24     || 0.9.8          || 18.0.1            ||
    90 || Git         || 2.7.4            || 1.9.1          || 2.1.4        || 1.7.10     || 1.8.3.1        || 2.6.6             ||
    91 || Subversion  || 1.9.3            || 1.8.8          || 1.8.10       || 1.6.17     || 1.7.14         || 1.8.10            ||
    92 || !DocUtils   || 0.12             || 0.11           || 0.12         || 0.8.1      || 0.11           || 0.11              ||
    93 || Textile     || 2.2.2            || 2.1.5          || 2.1.5        || 2.1.5      || n/a            || n/a               ||
    94 || Pygments    || 2.1              || 1.6            || 2.0.1        || 1.5        || 1.4            || 1.6               ||
    95 || Apache      || 2.4.18           || 2.4.7          || 2.4.10       || 2.2.22     || 2.4.6          || 2.4.16            ||
    96 || mod_wsgi    || 4.3.0            || 3.4            || 4.3.0        || 3.3        || 3.4            || 4.4.8             ||
    97 || mod_python  || 3.3.1            || 3.3.1          || 3.3.1        || 3.3.1      || n/a            || 3.5.0             ||
    98 || Nginx       || 1.10.0           || 1.4.6          || 1.6.2        || 1.2.1      || n/a            || 1.8.1             ||
    99 || **Last Updated** ||             ||                || 2017-05-25   ||            || 2018-02-13     ||                   ||
     78|| **Package** || **Ubuntu 16.04** || Ubuntu 14.04 || **Debian 9.3** || Debian 8.8 || Debian 7.8 || **CentOS 7.4** || **openSUSE 42.1** ||
     79|| Python      || 2.7.12           || 2.7.5        || 2.7.13         || 2.7.9        || 2.7.3      || 2.7.5          || 2.7.9             ||
     80|| Python3     || 3.5.2            || 3.4.0        || 3.5.3          || 3.4.2        || 3.2.3      || n/a            || 3.4.1             ||
     81|| Babel       || 1.3              || 1.3          || 2.3.4          || 1.3          || 0.9.6      || 0.9.6          || 1.3               ||
     82|| Genshi      || 0.7              || 0.7          || 0.7            || 0.7          || 0.6        || n/a            || 0.7               ||
     83|| SQLite3     || 3.11.0           || 3.8.2        || 3.16.2         || 3.8.7        || 3.7.13     || 3.7.17         || 3.8.10.2          ||
     84|| PostgreSQL  || 9.5.3            || 9.3.6        || 9.6.6          || 9.4.12       || 9.1.15     || 9.2.23         || 9.4, 9.3.11, 9.4.6 ||
     85|| MySQL       || 5.7.13           || 5.5.41, 5.6.19 || n/a          || 5.5.55       || 5.5.41     || n/a            || 5.6.30            ||
     86|| MariaDB     || 10.0.25          || 5.5.41       || 10.1.26        || 10.0.30      || n/a        || 5.5.56         || 10.0.22           ||
     87|| psycopg2    || 2.6.1            || 2.4.5        || 2.6.2          || 2.5.4        || 2.4.5      || 2.5.1          || 2.6               ||
     88|| PyMySQL     || 0.7.2            ||              || 0.7.10         || n/a          ||            || n/a            ||                   ||
     89|| SetupTools  || 20.7             || 3.3.1        || 33.1.1         || 5.5.1        || 0.6.24     || 0.9.8          || 18.0.1            ||
     90|| Git         || 2.7.4            || 1.9.1        || 2.11.0         || 2.1.4        || 1.7.10     || 1.8.3.1        || 2.6.6             ||
     91|| Subversion  || 1.9.3            || 1.8.8        || 1.9.5          || 1.8.10       || 1.6.17     || 1.7.14         || 1.8.10            ||
     92|| !DocUtils   || 0.12             || 0.11         || 0.13.1         || 0.12         || 0.8.1      || 0.11           || 0.11              ||
     93|| Textile     || 2.2.2            || 2.1.5        || 2.3.5          || 2.1.5        || 2.1.5      || n/a            || n/a               ||
     94|| Pygments    || 2.1              || 1.6          || 2.2.0          || 2.0.1        || 1.5        || 1.4            || 1.6               ||
     95|| Apache      || 2.4.18           || 2.4.7        || 2.4.25         || 2.4.10       || 2.2.22     || 2.4.6          || 2.4.16            ||
     96|| mod_wsgi    || 4.3.0            || 3.4          || 4.5.11         || 4.3.0        || 3.3        || 3.4            || 4.4.8             ||
     97|| mod_python  || 3.3.1            || 3.3.1        || 3.3.1          || 3.3.1        || 3.3.1      || n/a            || 3.5.0             ||
     98|| Nginx       || 1.10.0           || 1.4.6        || 1.10.3         || 1.6.2        || 1.2.1      || n/a            || 1.8.1             ||
     99|| **Last Updated** ||             ||              || 2018-02-13     || 2017-05-25   ||            || 2018-02-13     ||                   ||
    100100
    101101=== Deprecated Modules and APIs Removed