Edgewall Software

Changes between Version 24 and Version 25 of TracDev/ApiChanges/1.3


Ignore:
Timestamp:
May 26, 2017, 12:38:59 AM (5 years ago)
Author:
Ryan J Ollos
Comment:

Revise for changes made thus far.

Legend:

Unmodified
Added
Removed
Modified
  • TracDev/ApiChanges/1.3

    v24 v25  
    3737==== Jinja2 (mandatory)
    3838
    39 OPEN The plan is to apply the TracDev/Proposals/Jinja early in the 1.3.x development cycle.
     39Jinja2 >= 2.9.3 is required.
    4040
    4141==== Genshi (optional, deprecated)
    4242
    43 OPEN Jointly with the switch to Jinja2, Genshi support will be deprecated but kept functional for the whole 1.3.x cycle, and likely for the 1.4.x stable releases as well, in a similar spirit to what we did when we switched from ClearSilver to Genshi 10 years ago.
     43Genshi support is deprecated as the templating library, having been replaced by Jinja2. Genshi >= 0.6 is still needed to use many plugins.
    4444
    45 The goal is nevertheless to remove Genshi support during the 1.5.x development cycle, at the latest, so plugin developers will be urged to do the switch as well, as explained in PortingFromGenshiToJinja.
     45The goal is to remove Genshi support during the 1.5.x development cycle, at the latest, so plugin developers will be urged to do the switch as well, as explained in PortingFromGenshiToJinja.
    4646
    4747==== Databases
     
    4949|||| **Database** ||
    5050|| SQLite || >= 3.0 ||
    51 || PostgreSQL || >= 8.0 ||
     51|| PostgreSQL || >= 9.1.0 ||
    5252|| MySQL / MariaDB || >= 5.0 ||
    5353|||| **Database Bindings** ||
    54 || pysqlite || >= 2.4.1 (version provided by Python 2.6), avoid 2.5.2 - 2.5.4 ||
     54|| pysqlite || >= 2.6.0 (version provided by Python 2.7) ||
    5555|| psycopg2 || >= 2.0 ||
    5656|| MySQLdb  || >= 1.2.2 ||
     57|| PyMySQL  || ? ||
    5758
    5859==== Other
     
    6364|| Subversion  || Optional || >= 1.6 ||
    6465|| !DocUtils   || Optional || >= 0.3.9 ||
    65 || Textile    || Optional || >= 2.0 ||
    66 || Pygments   || Optional || >= 0.6. Let's consider bumping the requirement to at least 1.0, released in [https://pypi.python.org/pypi/Pygments/1.0 2008]  ||
    67 || passlib || Optional || Windows only ||
     66|| Textile     || Optional || >= 2.0 ||
     67|| Pygments    || Optional || >= 1.0  ||
     68|| passlib     || Optional || Windows only ||
    6869
    6970==== Compatible Distros