Edgewall Software

Changes between Version 11 and Version 12 of TracDev/ApiChanges/1.3


Ignore:
Timestamp:
Jun 7, 2015, 10:54:31 AM (7 years ago)
Author:
Ryan J Ollos
Comment:

Placeholder for openSUSE

Legend:

Unmodified
Added
Removed
Modified
  • TracDev/ApiChanges/1.3

    v11 v12  
    6161The supported dependencies were determined by aiming to be compatible with the versions provided by the package managers on the following distros.
    6262
    63 || **Package** || **Ubuntu 14.04** || **Debian 8** || Debian 7.8 || **CentOS 7.1.1503** || CentOS 6.6 ||
    64 || Python      || 2.7.5            || 2.7.9        || 2.7.3      || 2.7.5               || 2.6.6      ||
    65 || Babel       || 1.3              || 1.3          || 0.9.6      || 0.9.6               || 0.9.4      ||
    66 || Genshi      || 0.7              || 0.7          || 0.6        || n/a                 || n/a        ||
    67 || SQLite      || 3.8.2            || 3.8.7        || 3.7.13     || 3.7.17              || 3.6.20     ||
    68 || PostgreSQL  || 9.3.6            || 9.4.1        || 9.1.15     || 9.2.10              || 8.4.20     ||
    69 || MySQL       || 5.5.41, 5.6.19   || 5.5.42       || 5.5.41     || n/a                 || 5.1.73     ||
    70 || MariaDB     || 5.5.41           || 10.0.16      || n/a        || 5.5.41              || n/a        ||
    71 || psycopg2    || 2.4.5            || 2.5.4        || 2.4.5      || 2.5.1               || 2.0.14     ||
    72 || MySQLdb     || 1.2.3            || 1.2.3        || 1.2.3      || 1.2.3               || 1.2.3      ||
    73 || SetupTools  || 3.3.1            || 5.5.1        || 0.6.24     || 0.9.8               || 0.6.10     ||
    74 || Git         || 1.9.1            || 2.1.4        || 1.7.10     || 1.8.3.1             || 1.7.1      ||
    75 || Subversion  || 1.8.8            || 1.8.10       || 1.6.17     || 1.7.14              || 1.6.11     ||
    76 || !DocUtils   || 0.11             || 0.12         || 0.8.1      || 0.11                || 0.6        ||
    77 || Textile     || 2.1.5            || 2.1.5        || 2.1.5      || n/a                 || n/a        ||
    78 || Pygments    || 1.6              || 2.0.1        || 1.5        || 1.4                 || 1.1.1      ||
    79 || Apache      || 2.4.7            || 2.4.10       || 2.2.22     || 2.4.6               || 2.2.15     ||
    80 || mod_wsgi    || 3.4              || 4.3.0        || 3.3        || 3.4                 || 3.2        ||
    81 || mod_python  || 3.3.1            || 3.3.1        || 3.3.1      || n/a                 || n/a        ||
    82 || Nginx       || 1.4.6            || 1.6.2        || 1.2.1      || n/a                 || n/a        ||
     63|| **Package** || **Ubuntu 14.04** || **Debian 8** || Debian 7.8 || **CentOS 7.1.1503** || CentOS 6.6 || **openSUSE 13.2** ||
     64|| Python      || 2.7.5            || 2.7.9        || 2.7.3      || 2.7.5               || 2.6.6      || ||
     65|| Babel       || 1.3              || 1.3          || 0.9.6      || 0.9.6               || 0.9.4      || ||
     66|| Genshi      || 0.7              || 0.7          || 0.6        || n/a                 || n/a        || ||
     67|| SQLite      || 3.8.2            || 3.8.7        || 3.7.13     || 3.7.17              || 3.6.20     || ||
     68|| PostgreSQL  || 9.3.6            || 9.4.1        || 9.1.15     || 9.2.10              || 8.4.20     || ||
     69|| MySQL       || 5.5.41, 5.6.19   || 5.5.42       || 5.5.41     || n/a                 || 5.1.73     || ||
     70|| MariaDB     || 5.5.41           || 10.0.16      || n/a        || 5.5.41              || n/a        || ||
     71|| psycopg2    || 2.4.5            || 2.5.4        || 2.4.5      || 2.5.1               || 2.0.14     || ||
     72|| MySQLdb     || 1.2.3            || 1.2.3        || 1.2.3      || 1.2.3               || 1.2.3      || ||
     73|| SetupTools  || 3.3.1            || 5.5.1        || 0.6.24     || 0.9.8               || 0.6.10     || ||
     74|| Git         || 1.9.1            || 2.1.4        || 1.7.10     || 1.8.3.1             || 1.7.1      || ||
     75|| Subversion  || 1.8.8            || 1.8.10       || 1.6.17     || 1.7.14              || 1.6.11     || ||
     76|| !DocUtils   || 0.11             || 0.12         || 0.8.1      || 0.11                || 0.6        || ||
     77|| Textile     || 2.1.5            || 2.1.5        || 2.1.5      || n/a                 || n/a        || ||
     78|| Pygments    || 1.6              || 2.0.1        || 1.5        || 1.4                 || 1.1.1      || ||
     79|| Apache      || 2.4.7            || 2.4.10       || 2.2.22     || 2.4.6               || 2.2.15     || ||
     80|| mod_wsgi    || 3.4              || 4.3.0        || 3.3        || 3.4                 || 3.2        || ||
     81|| mod_python  || 3.3.1            || 3.3.1        || 3.3.1      || n/a                 || n/a        || ||
     82|| Nginx       || 1.4.6            || 1.6.2        || 1.2.1      || n/a                 || n/a        || ||
    8383
    8484=== Deprecated Modules Removed