Edgewall Software

Opened 13 years ago

Last modified 13 years ago

#4635 closed defect

Internal Server Error — at Version 1

Reported by: jtaylor1126@… Owned by: Christian Boos
Priority: high Milestone: 0.10.4
Component: version control/browser Version:
Severity: normal Keywords: documentation
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

I get the following traceback when I attempt to run tracd using a recently initialized environment accepting the defaults except for the repository directories.

Traceback (most recent call last):
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 191, in dispatch
    chosen_handler = self._pre_process_request(req, chosen_handler)
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 263, in _pre_process_request
    chosen_handler = f.pre_process_request(req, chosen_handler)
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\api.py", line 73, in pre_process_request
    self.get_repository(req.authname) # triggers a sync if applicable
  File "C:\Python24\Lib\site-packages\trac\versioncontrol\api.py", line 91, in get_repository
    raise TracError('Unsupported version control system "%s"'
TracError: Unsupported version control system "svn

Change History (1)

comment:1 by Christian Boos, 13 years ago

Description: modified (diff)
Keywords: documentation added
Milestone: 0.10.4
Priority: normalhigh

This was already reported a lot of times, it's a common installation issue.

You don't have the Subversion bindings correctly installed. I think we should make the exception message more explicit about this.

Note: See TracTickets for help on using tickets.