Edgewall Software

Changes between Initial Version and Version 1 of Ticket #11377, comment 5


Ignore:
Timestamp:
Feb 16, 2014, 8:32:47 PM (10 years ago)
Author:
Ryan J Ollos

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #11377, comment 5

    initial v1  
    22> I think we should add //modified_ticket_comment// and //deleted_ticket_comment// methods to `ITicketChangeListener` because it seems that we need more time to fix #11148. Thoughts?
    33
    4 I think it makes sense to add the methods to `ITicketChangeListener`. To have consistency in naming with `ticket_created`, `ticket_change` and `ticket_deleted`, the names `ticket_comment_modified` and `ticket_comment_deleted` seem better to me (or even `comment_modified`, `comment_deleted`; as long as the verb goes last).
     4I think it makes sense to add the methods to `ITicketChangeListener` in 1.0.x. To have consistency in naming with `ticket_created`, `ticket_change` and `ticket_deleted`, the names `ticket_comment_modified` and `ticket_comment_deleted` seem better to me (or even `comment_modified`, `comment_deleted`; as long as the verb goes last).
    55
    66In the case of deleting a comment though, we are really deleting a //change//, which includes ticket properties: `Ticket.delete_change` is called by `TicketDeleter`. When editing a comment, `Ticket.modify_comment` is called, but perhaps we should make the interface more generic for cases that properties might be edited through a plugin. So should the methods be `ticket_change_modified` and `ticket_change_deleted`?